summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-04 21:29:03 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:35 +0100
commit102003edfc7d4689ec7ef21c5bb0dc2d4053d7ed (patch)
tree66d1c1db68efd76b36b690f2aab2e89844fb30d7
parent43923d2459e839a6ce3281c6ef3149d807f42c95 (diff)
gnu: python-lightning-cloud: Update to 0.5.70.
* gnu/packages/machine-learning.scm (python-lightning-cloud): Update to 0.5.70. [propagated-inputs]: Add python-boto3 and python-protobuf; replace python-fastapi-for-pytorch-lightning with python-fastapi. Change-Id: I4c93a0120639af230fdaf53703c688ce3012e8e0
-rw-r--r--gnu/packages/machine-learning.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 4bba4534cc..efa20c3d74 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -5142,18 +5142,20 @@ Neural Networks for a wide range of applications related to structured data.")
(define-public python-lightning-cloud
(package
(name "python-lightning-cloud")
- (version "0.5.34")
+ (version "0.5.70")
(source (origin
(method url-fetch)
(uri (pypi-uri "lightning_cloud" version))
(sha256
(base32
- "0mqrhq3s23mn8n4i0q791pshn3dgplp0h9ny0pmmp798q0798dzs"))))
+ "11xx7w7ypyf6bzwz7pbdakap68a1lnsv3icis8wm8magkfglash2"))))
(arguments (list #:tests? #f)) ; no tests in PyPI archive.
(build-system pyproject-build-system)
- (propagated-inputs (list python-click
- python-fastapi-for-pytorch-lightning
+ (propagated-inputs (list python-boto3
+ python-click
+ python-fastapi
python-multipart
+ python-protobuf
python-pyjwt
python-requests
python-rich