summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <[email protected]>2024-08-20 16:54:57 +0200
committerLudovic Courtès <[email protected]>2024-08-31 19:06:37 +0200
commit1003d62790c32a5bf33fb09de590bbe459fb39d7 (patch)
treee3fd9caa525e6925900f89ed2241bf2a1dc10925
parent6dac85c092d21de6178a714635acb737b265509c (diff)
gnu: libfabric: Depend on PSM2 only on supported systems.
Fixes a regression introduced in 2a6ea3895bf554a70c699a1013d75ffa5407bcad, that would make ‘libfabric’ unsupported on non-x86_64 systems. * gnu/packages/linux.scm (libfabric)[inputs]: Define ‘if-supported’. Use it for ‘psm’ and ‘psm2, and remove labels. [arguments]: Remove ‘--enable-psm2’, which is unnecessary. Change-Id: I2a52ce6feb52b8773779a401088743491c3ad30b
-rw-r--r--gnu/packages/linux.scm21
1 files changed, 12 insertions, 9 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3ef6479377..318c6ccf13 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8903,17 +8903,20 @@ comparing system environments.")
(sha256
(base32 "1znmw83rmippv0fwz0x7lgylfk17dr9ckll8lrm4z7kclspnqpj8"))))
(build-system gnu-build-system)
- (inputs `(("rdma-core" ,rdma-core)
- ,@(match (%current-system)
- ((member (package-supported-systems psm))
- `(("psm" ,psm)))
- (_ `()))
- ("psm2" ,psm2)
- ("libnl" ,libnl)))
+ (inputs
+ (let ((if-supported ;XXX: copied from openmpi
+ (lambda (package)
+ (if (and (not (%current-target-system))
+ (member (%current-system)
+ (package-supported-systems package)))
+ (list package)
+ '()))))
+ (append (list rdma-core libnl)
+ (if-supported psm)
+ (if-supported psm2))))
(arguments
(list #:configure-flags
- #~(list "--enable-psm2"
- "--enable-efa"
+ #~(list "--enable-efa"
"--enable-verbs")))
(home-page "https://ofiwg.github.io/libfabric/")
(synopsis "Open Fabric Interfaces")