summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-22 13:24:04 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:14 +0000
commit088bdaed4c1904ca0274a563525e160cbf4a2a29 (patch)
tree83631c141fda7e600b1009c9281e0f3cba102a7f
parent795df3416677e62a52aed89d8798362e7dae3251 (diff)
gnu: go-github-com-pion-transport-v2: Fix import paths.
* gnu/packages/golang-web.scm (go-github-com-pion-transport-v2): [arguments] <phases>: Add 'fix-module-paths, they were not adjusted in source when v2 was released. Change-Id: Ie28bcc3921bbe76e3721340af76a3dad6b8c53e3
-rw-r--r--gnu/packages/golang-web.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index fb1778aa46..d1f38a4068 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -5240,7 +5240,14 @@ throughout the @url{https://github.com/pion, Pion} modules.")
(base32 "0g5pg6mz61blprccxzysbwldkil84qgwp6404lsp4m9wh44312hf"))))
(arguments
(list
- #:import-path "github.com/pion/transport/v2"))
+ #:import-path "github.com/pion/transport/v2"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-module-paths
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* (find-files "." "\\.go$")
+ (("github.com/pion/transport/v3") import-path))))))))
(native-inputs
(list go-github-com-stretchr-testify))
(propagated-inputs