aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in57
1 files changed, 46 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 7150e5fa0b..76fd9a4817 100644
--- a/configure.in
+++ b/configure.in
@@ -24,8 +24,9 @@ dnl Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
dnl Boston, MA 02110-1301, USA.
AC_PREREQ(2.61)dnl
-AC_INIT(src/lisp.h)
+AC_INIT(emacs, 23.0.50)
AC_CONFIG_HEADER(src/config.h:src/config.in)
+AC_CONFIG_SRCDIR(src/lisp.h)
dnl Support for --program-prefix, --program-suffix and
dnl --program-transform-name options
@@ -120,6 +121,7 @@ EMACS_ARG_N([toolkit-scroll-bars],[don't use Motif or Xaw3d scroll bars])
EMACS_ARG_N([xaw3d],[don't use Xaw3d])
EMACS_ARG_N([xim],[don't use X11 XIM])
EMACS_ARG_N([carbon],[don't use Carbon GUI on Mac OS X])
+EMACS_ARG_N([dbus],[don't use D-Bus])
AC_ARG_ENABLE(carbon-app,
[AS_HELP_STRING([--enable-carbon-app@<:@=DIR@:>@],
@@ -253,6 +255,19 @@ case "${canonical}" in
esac
;;
+ ## FreeBSD kernel + glibc based userland
+ *-*-kfreebsd*gnu* )
+ opsys=gnu-kfreebsd
+ case "${canonical}" in
+ alpha*-*-kfreebsd*) machine=alpha ;;
+ ia64-*-kfreebsd*) machine=ia64 ;;
+ sparc64-*-kfreebsd*) machine=sparc ;;
+ powerpc-*-kfreebsd*) machine=macppc ;;
+ i[3456]86-*-kfreebsd*) machine=intel386 ;;
+ amd64-*-kfreebsd*|x86_64-*-kfreebsd*) machine=amdx86-64 ;;
+ esac
+ ;;
+
## NetBSD ports
*-*-netbsd* )
opsys=netbsd
@@ -1193,7 +1208,7 @@ dnl see the `changequote' comment above.
machine=amdx86-64 opsys=gnu-linux
;;
- ## Tensilica Xtensa Linux-based GNU system
+ ## Tensilica Xtensa Linux-based GNU system
xtensa-*-linux-gnu* )
machine=xtensa opsys=gnu-linux
;;
@@ -1351,11 +1366,11 @@ AC_PATH_PROG(GZIP_PROG, gzip)
## Need makeinfo >= 4.6 (?) to build the manuals.
AC_PATH_PROG(MAKEINFO, makeinfo, no)
-dnl By this stage, configure has already checked for egrep and set EGREP,
+dnl By this stage, configure has already checked for egrep and set EGREP,
dnl or exited with an error if no egrep was found.
if test "$MAKEINFO" != "no" && \
test x"`$MAKEINFO --version 2> /dev/null | $EGREP 'texinfo[[^0-9]]*([[1-4]][[0-9]]+|[[5-9]]|4\.[[6-9]]|4\.[[1-5]][[0-9]]+)'`" = x; then
- MAKEINFO=no
+ MAKEINFO=no
fi
if test "$MAKEINFO" = "no"; then
@@ -1547,7 +1562,7 @@ dnl Do this early because it can frob feature test macros for Unix-98 &c.
AC_SYS_LARGEFILE
-### The standard library on x86-64 GNU/Linux distributions can
+### The standard library on x86-64 GNU/Linux distributions can
### be located in either /usr/lib64 or /usr/lib.
case "${canonical}" in
x86_64-*-linux-gnu* )
@@ -1898,7 +1913,7 @@ dnl USE_X_TOOLKIT is set.
no ) USE_X_TOOLKIT=none ;;
dnl If user did not say whether to use a toolkit, make this decision later:
dnl use the toolkit if we have gtk, or X11R5 or newer.
- * )
+ * )
if test x"$with_gtk" = xyes; then
USE_X_TOOLKIT=none
else
@@ -1917,7 +1932,7 @@ esac
if test "$window_system" = none && test "X$with_x" != "Xno"; then
AC_CHECK_PROG(HAVE_XSERVER, X, true, false)
if test "$HAVE_XSERVER" = true ||
- test -n "$DISPLAY" ||
+ test -n "$DISPLAY" ||
test "`echo /usr/lib/libX11.*`" != "/usr/lib/libX11.*"; then
AC_MSG_ERROR([You seem to be running X, but no X development libraries
were found. You should install the relevant development files for X
@@ -2252,6 +2267,17 @@ if test "${HAVE_GTK}" = "yes"; then
fi
fi
+dnl D-Bus has been tested under GNU/Linux only. Must be adapted for
+dnl other platforms. Support for higher D-Bus versions but 1.0 is
+dnl also not configured.
+HAVE_DBUS=no
+if test "${with_dbus}" = "yes"; then
+ PKG_CHECK_MODULES(DBUS, dbus-1 >= 1.0, HAVE_DBUS=yes, HAVE_DBUS=no)
+ if test "$HAVE_DBUS" = yes; then
+ AC_DEFINE(HAVE_DBUS, 1, [Define to 1 if using D-Bus.])
+ fi
+fi
+
dnl Do not put whitespace before the #include statements below.
dnl Older compilers (eg sunos4 cc) choke on it.
HAVE_XAW3D=no
@@ -2836,15 +2862,19 @@ AC_CHECK_LIB(ncurses, tparm)
# Do we have res_init, for detecting changes in /etc/resolv.conf?
resolv=no
-AC_CHECK_FUNC(res_init, have_res_init=yes, have_res_init=no)
+AC_TRY_LINK([#include <netinet/in.h>
+#include <arpa/nameser.h>
+#include <resolv.h>],
+ [return res_init();],
+ have_res_init=yes, have_res_init=no)
if test "$have_res_init" = no; then
OLIBS="$LIBS"
LIBS="$LIBS -lresolv"
AC_MSG_CHECKING(for res_init with -lresolv)
AC_TRY_LINK([#include <netinet/in.h>
#include <arpa/nameser.h>
-#include <resolv.h> ],
- [res_init();],
+#include <resolv.h>],
+ [return res_init();],
have_res_init=yes, have_res_init=no)
AC_MSG_RESULT($have_res_init)
if test "$have_res_init" = yes ; then
@@ -3538,7 +3568,12 @@ if test "$HAVE_CARBON" = "yes"; then
known problems. It is not recommended for use by non-developers.
Read the emacs-devel archives for more information."
echo
-fi
+fi
+
+if test "$HAVE_DBUS" = yes && test "${opsys}" != "gnu-linux"; then
+ echo "D-Bus integration has been tested for GNU/Linux only."
+ echo
+fi
# Remove any trailing slashes in these variables.