aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGerd Moellmann <[email protected]>2000-09-14 15:11:53 +0000
committerGerd Moellmann <[email protected]>2000-09-14 15:11:53 +0000
commite32fac2a98e6626d42ad4fc2ab900f6f7ddd64be (patch)
tree2b933c0ff94cad867dbd2e60e1c884a90b39a856 /configure.in
parent896160ba9652a0c64ba4db0f6f86e7312b684f13 (diff)
(USE_MMAP_FOR_BUFFERS): Recognize in system
configuration files instead of REL_ALLOC_MMAP. Set REL_ALLOC to `no' if defined. Change result report.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 1642f23047..d649841b58 100644
--- a/configure.in
+++ b/configure.in
@@ -1228,10 +1228,10 @@ configure___ system_malloc=yes
configure___ system_malloc=no
#endif
-#ifdef REL_ALLOC_MMAP
-configure___ rel_alloc_mmap=yes
+#ifdef USE_MMAP_FOR_BUFFERS
+configure___ use_mmap_for_buffers=yes
#else
-configure___ rel_alloc_mmap=no
+configure___ use_mmap_for_buffers=no
#endif
#ifndef C_DEBUG_SWITCH
@@ -1544,13 +1544,13 @@ if test x"${REL_ALLOC}" = x; then
REL_ALLOC=${GNU_MALLOC}
fi
-dnl For now, need to use an explicit `#define REL_ALLOC_MMAP 1' in
-dnl the system configuration file (s/*.h) to turn the use of mmap
+dnl For now, need to use an explicit `#define USE_MMAP_FOR_BUFFERS 1'
+in dnl the system configuration file (s/*.h) to turn the use of mmap
dnl in the relocating allocator on.
AC_FUNC_MMAP
-if test $rel_alloc_mmap = yes; then
- REL_ALLOC=yes
+if test $use_mmap_for_buffers = yes; then
+ REL_ALLOC=no
fi
LIBS="$libsrc_libs $LIBS"
@@ -2195,7 +2195,7 @@ Configured for \`${canonical}'.
What compiler should emacs be built with? ${CC} ${CFLAGS}
Should Emacs use the GNU version of malloc? ${GNU_MALLOC}${GNU_MALLOC_reason}
Should Emacs use a relocating allocator for buffers? ${REL_ALLOC}
- Should Emacs use mmap for the relocating allocator? $rel_alloc_mmap
+ Should Emacs use mmap(2) for buffer allocation? $use_mmap_for_buffers
What window system should Emacs use? ${window_system}
What toolkit should Emacs use? ${USE_X_TOOLKIT}"