aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <[email protected]>2011-05-14 12:52:13 -0700
committerGlenn Morris <[email protected]>2011-05-14 12:52:13 -0700
commitd681f183cfe5347915f74a38078cb13f8c4ce2c2 (patch)
tree85bea7aaf8200e91f38697e5be1cc169fe9b2297 /configure.in
parent4691905a95e3a70a0a3eb538a0af1164ce0af8f1 (diff)
Make configure.in give an error if no X-toolkit was detected.
* configure.in: Treat failure to find an X toolkit the same way we treat failure to find X and image support.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index f46645c1bd..5d2992539f 100644
--- a/configure.in
+++ b/configure.in
@@ -2036,8 +2036,11 @@ if test x"${USE_X_TOOLKIT}" = xmaybe || test x"${USE_X_TOOLKIT}" = xLUCID; then
elif test x"${USE_X_TOOLKIT}" = xLUCID; then
AC_MSG_ERROR([Lucid toolkit requires X11/Xaw include files])
else
- AC_MSG_RESULT([no; do not use toolkit by default])
- USE_X_TOOLKIT=none
+ AC_MSG_ERROR([No X toolkit could be found.
+If you are sure you want Emacs compiled without an X toolkit, pass
+ --with-x-toolkit=no
+to configure. Otherwise, install the development libraries for the toolkit
+that you want to use (e.g. Gtk+) and re-run configure.])
fi
fi
fi