aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJan Djärv <[email protected]>2008-03-11 08:14:28 +0000
committerJan Djärv <[email protected]>2008-03-11 08:14:28 +0000
commitca34d75a59d42b2a9f11a2f6b754ef21005fbdfd (patch)
tree8fb3260a8e625c9cd9ae909eaf02c78c611a5f16 /configure.in
parent191a057dc06f06388accfc0aaa7647a734372b67 (diff)
Add --enable-sync-input, default yes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e8a7ab20e0..72d4863f55 100644
--- a/configure.in
+++ b/configure.in
@@ -173,6 +173,11 @@ AC_ARG_ENABLE(font-backend,
USE_FONT_BACKEND=$enableval,
USE_FONT_BACKEND=yes)
+AC_ARG_ENABLE(sync-input,
+[AS_HELP_STRING([--enable-sync-input], [compile code with sync-input])],
+ USE_SYNC_INPUT=$enableval,
+ USE_SYNC_INPUT=yes)
+
AC_ARG_ENABLE(asserts,
[AS_HELP_STRING([--enable-asserts], [compile code with asserts enabled])],
USE_XASSERTS=$enableval,
@@ -3001,9 +3006,15 @@ echo
if test $USE_XASSERTS = yes; then
echo " Compiling with asserts turned on."
CPPFLAGS="$CPPFLAGS -DXASSERTS=1"
- echo
fi
+if test $USE_SYNC_INPUT = yes; then
+ echo " Compiling with sync input."
+ CPPFLAGS="$CPPFLAGS -DSYNC_INPUT=1"
+fi
+
+echo
+
if test "$USE_X_TOOLKIT" = GTK; then
case "$canonical" in
*cygwin*)