aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGerd Moellmann <[email protected]>2000-06-26 15:38:07 +0000
committerGerd Moellmann <[email protected]>2000-06-26 15:38:07 +0000
commitc6f7dae8280565b3f2b357967787d3d1849ee499 (patch)
tree91f4b69442289da283cc3130e3eae38364b1657f /configure.in
parentcab90cd8570f914040c42aa7d6129dee868ff17a (diff)
(--with-xim): New option.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a7a3e3a9a5..1152b795d8 100644
--- a/configure.in
+++ b/configure.in
@@ -94,7 +94,9 @@ AC_ARG_WITH(png,
[ --with-png use -lpng for displaying PNG images])
AC_ARG_WITH(toolkit-scroll-bars,
[ --without-toolkit-scroll-bars
- don't use Motif or Xaw3d scroll bars])
+ don't use Motif or Xaw3d scroll bars])
+AC_ARG_WITH(xim,
+[ --without-xim don't use X11 XIM])
#### Make srcdir absolute, if it isn't already. It's important to
#### avoid running the path through pwd unnecessary, since pwd can
@@ -1742,6 +1744,13 @@ if test "${with_toolkit_scroll_bars}" != "no"; then
fi
fi
+dnl Don't use X11 input methods if user specifies he doesn't want it
+dnl with `--with-xim=no'.
+
+if test "${with_xim}" != "no"; then
+ AC_DEFINE(USE_XIM)
+fi
+
### Use -lXpm if available, unless `--with-xpm=no'.
HAVE_XPM=no
if test "${HAVE_X11}" = "yes"; then