aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <[email protected]>2010-05-25 23:41:58 -0700
committerGlenn Morris <[email protected]>2010-05-25 23:41:58 -0700
commit90278cb61102b1bcf2c9a2837cb301af06a18127 (patch)
tree4ecd18fa52c2317a32ab158489880080853a2507 /configure.in
parent021eb8d750547099c7edcb537f46478276d7dc8c (diff)
Replace YMF_PASS_LDFLAGS with autoconf.
* configure.in (YMF_PASS_LDFLAGS): Remove. (PRE_EDIT_LDFLAGS, POST_EDIT_LDFLAGS): New output variables. * configure: Regenerate. * src/Makefile.in (YMF_PASS_LDFLAGS): Remove. (temacs${EXEEXT}): Use PRE_EDIT_LDFLAGS, POST_EDIT_LDFLAGS. * msdos/sed1v2.inp (@PRE_EDIT_LDFLAGS@, @POST_EDIT_LDFLAGS@): Edit to nothing.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 01b52e3e38..7cdf520dc5 100644
--- a/configure.in
+++ b/configure.in
@@ -3335,11 +3335,9 @@ case "$opsys" in
;;
esac
-## A macro which other sections of Makefile can redefine to munge the
-## flags before they are passed to LD. This is helpful if you have
-## redefined LD to something odd, like "gcc".
-## (The YMF prefix is a holdover from the old name "ymakefile".)
-YMF_PASS_LDFLAGS=flags
+
+PRE_EDIT_LDFLAGS=
+POST_EDIT_LDFLAGS=
if test "x$ORDINARY_LINK" = "xyes"; then
LINKER="\$(CC)"
@@ -3363,10 +3361,12 @@ elif test "x$GCC" = "xyes" && test "x$LINKER" = "x"; then
## shell''s ``for'' construct. Note that sane people do not have '.' in
## their paths, so we must use ./prefix-args.
## TODO either make prefix-args check ORDINARY_LINK internally,
- ## or remove it altogether (bug#6184), removing the need for this macro.
- YMF_PASS_LDFLAGS='`./prefix-args -Xlinker flags`'
+ ## or remove it altogether (bug#6184), removing the need for this hack.
+ PRE_EDIT_LDFLAGS='`./prefix-args -Xlinker'
+ POST_EDIT_LDFLAGS='`'
fi
-AC_SUBST(YMF_PASS_LDFLAGS)
+AC_SUBST(PRE_EDIT_LDFLAGS)
+AC_SUBST(POST_EDIT_LDFLAGS)
test "x$LINKER" = "x" && LINKER=ld
## FIXME? What setting of YMF_PASS_LDFLAGS should this have?