aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <[email protected]>2008-02-06 07:57:33 +0000
committerGlenn Morris <[email protected]>2008-02-06 07:57:33 +0000
commit86dc59b0f79fcb6ddf8a8623bc3733f81a7cd127 (patch)
treee80af6d8c2af92a8a8bf110725884ab870c51eaf /configure.in
parent02f35af2461cbdf5666f3a4fce4e73a891540cb2 (diff)
(--with-gcc): Give an error saying this option has been removed.
(--with-gtk): Remove this option.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 13 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index d9124150c3..57aa340544 100644
--- a/configure.in
+++ b/configure.in
@@ -135,7 +135,6 @@ OPTION_DEFAULT_ON([xft],[don't use XFT for anti aliased fonts])
OPTION_DEFAULT_ON([libotf],[don't use libotf for OpenType font support])
OPTION_DEFAULT_ON([m17n-flt],[don't use m17n-flt for text shaping])
-OPTION_DEFAULT_OFF([gtk],[use GTK toolkit])
OPTION_DEFAULT_ON([toolkit-scroll-bars],[don't use Motif or Xaw3d scroll bars])
OPTION_DEFAULT_ON([xaw3d],[don't use Xaw3d])
OPTION_DEFAULT_ON([xim],[don't use X11 XIM])
@@ -144,6 +143,15 @@ OPTION_DEFAULT_OFF([carbon],[use Carbon GUI on Mac OS X. This is unsupported!])
OPTION_DEFAULT_ON([gpm],[don't use -lgpm for mouse support on a GNU/Linux console])
OPTION_DEFAULT_ON([dbus],[don't compile with D-Bus support])
+dnl Can remove these in Emacs 24.
+AC_ARG_WITH([gtk],,
+ AC_MSG_ERROR([--with-gtk has been removed. Use --with-x-toolkit to
+specify a toolkit.]),,)
+
+AC_ARG_WITH([gcc],,
+ AC_MSG_ERROR([--with-gcc has been removed. Set the `CC' environment
+ variable to specify a compiler.]),,)
+
AC_ARG_WITH([pkg-config-prog],dnl
[AS_HELP_STRING([--with-pkg-config-prog=PATH],
[Path to pkg-config for finding GTK and librsvg])])
@@ -821,6 +829,7 @@ test -n "$CC" && cc_specified=yes
# Save the value of CFLAGS that the user specified.
SPECIFIED_CFLAGS="$CFLAGS"
+dnl Sets GCC=yes if using gcc.
AC_PROG_CC
# On Suns, sometimes $CPP names a directory.
@@ -1422,7 +1431,7 @@ fi
if test "${window_system}" = x11 && test "${HAVE_CARBON}" = yes; then
if test "${with_carbon+set}" != set \
&& test "${carbon_appdir_x+set}" != set; then
- for var in with_x with_x_toolkit with_gtk with_xim \
+ for var in with_x with_x_toolkit with_xim \
with_xpm with_jpeg with_tiff with_gif with_png; do
if eval test \"\${$var+set}\" = set; then
HAVE_CARBON=no
@@ -1449,13 +1458,7 @@ dnl USE_X_TOOLKIT is set.
no ) USE_X_TOOLKIT=none ;;
dnl If user did not say whether to use a toolkit, make this decision later:
dnl use the toolkit if we have gtk, or X11R5 or newer.
- * )
- if test x"$with_gtk" = xyes; then
- USE_X_TOOLKIT=none
- else
- USE_X_TOOLKIT=maybe
- fi
- ;;
+ * ) USE_X_TOOLKIT=maybe ;;
esac
;;
mac | none )
@@ -1683,14 +1686,7 @@ fi
HAVE_GTK=no
-if test "${with_gtk}" = "yes" && test "$USE_X_TOOLKIT" = "gtk"; then
- USE_X_TOOLKIT=none
-fi
-if test "${with_gtk}" = "yes" || test "$USE_X_TOOLKIT" = "gtk" || \
- test "$USE_X_TOOLKIT" = "maybe"; then
- if test "$USE_X_TOOLKIT" != "none" && test "$USE_X_TOOLKIT" != "maybe"; then
- AC_MSG_ERROR([Conflicting options, --with-gtk is incompatible with --with-x-toolkit=${with_x_toolkit}]);
- fi
+if test "${with_gtk}" = "yes" || test "$USE_X_TOOLKIT" = "maybe"; then
GLIB_REQUIRED=2.6
GTK_REQUIRED=2.6
GTK_MODULES="gtk+-2.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED"