aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAndreas Schwab <[email protected]>2009-07-04 08:12:10 +0000
committerAndreas Schwab <[email protected]>2009-07-04 08:12:10 +0000
commit7df24305ed8d85172aaa9084ed5b3f7d8e354bba (patch)
treeb6a85fcf1361fbfd9e8b06f4eababafa50c32ac9 /configure.in
parent0a3472c7b938d9469e9c4b304798c7eacf8b3330 (diff)
(--enable-checking, --enable-profiling): Use
AS_HELP_STRING.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 414d9b236b..b6257a5b06 100644
--- a/configure.in
+++ b/configure.in
@@ -210,12 +210,12 @@ elif test "${enableval}" != "yes"; then
fi)
AC_ARG_ENABLE(checking,
-[ --enable-checking[=LIST]
- enable expensive run-time checks. With LIST,
- enable only specific categories of checks.
- Categories are: all,yes,no.
- Flags are: stringbytes, stringoverrun, stringfreelist,
- xmallocoverrun, conslist],
+[AS_HELP_STRING([--enable-checking@<:@=LIST@:>@],
+ [enable expensive run-time checks. With LIST,
+ enable only specific categories of checks.
+ Categories are: all,yes,no.
+ Flags are: stringbytes, stringoverrun, stringfreelist,
+ xmallocoverrun, conslist])],
[ac_checking_flags="${enableval}"],[])
IFS="${IFS= }"; ac_save_IFS="$IFS"; IFS="$IFS,"
for check in $ac_checking_flags
@@ -274,9 +274,9 @@ if test x$ac_gc_check_cons_list != x ; then
fi
AC_ARG_ENABLE(profiling,
-[ --enable-profiling
- Build emacs with profiling support.
- This might not work on all platforms.],
+[AS_HELP_STRING([--enable-profiling],
+ [build emacs with profiling support.
+ This might not work on all platforms])],
[ac_enable_profiling="${enableval}"],[])
if test x$ac_enable_profiling != x ; then
PROFILING_CFLAGS="-DPROFILING=1 -pg"