aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <[email protected]>2010-05-21 09:31:45 -0700
committerGlenn Morris <[email protected]>2010-05-21 09:31:45 -0700
commit6a6dbaceca1daa7f5e86c05eb3e7d4d71dbf40fc (patch)
treed502612e1058bf03e21cd67c91be2f054155ea6c /configure.in
parent655bded0bf82afaf61f03d9437ebe48bf25f9bc5 (diff)
* configure.in (MKDEPDIR): Parallel build tweak.
* src/Makefile.in: Comment.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6d82a20351..36359e2507 100644
--- a/configure.in
+++ b/configure.in
@@ -1376,7 +1376,10 @@ if test "$GCC" = yes && test "$ac_enable_autodepend" = yes; then
fi
if test $ac_enable_autodepend = yes; then
DEPFLAGS='-MMD -MF ${DEPDIR}/$*.d'
- MKDEPDIR='test -d ${DEPDIR} || mkdir ${DEPDIR}'
+ ## In parallel builds, another make might create depdir between
+ ## the first test and mkdir, so stick another test on the end.
+ ## Or use mkinstalldirs? mkdir -p is not portable.
+ MKDEPDIR='test -d ${DEPDIR} || mkdir ${DEPDIR} || test -d ${DEPDIR}'
deps_frag=autodeps.mk
fi
fi