aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <[email protected]>2008-01-25 04:32:52 +0000
committerGlenn Morris <[email protected]>2008-01-25 04:32:52 +0000
commit5b940d5a6974b2ec2a0090f8a77958c6d97b2df0 (patch)
tree19d4525337880087abbdd2e1feacdf98b833115e /configure.in
parente0df1b73db61b652198ab72a7ab0d9791f29a0a8 (diff)
Correct usage of OPTION_DEFAULT_ON, OPTION_DEFAULT_OFF so that the
defaults are as they used to be. Default `Carbon' to off (it's unsupported).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 16 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index a13c1f3137..950e86d8a0 100644
--- a/configure.in
+++ b/configure.in
@@ -101,6 +101,7 @@ fi
OPTION_DEFAULT_ON([sound],[don't compile with sound support])
+dnl FIXME currently it is not the last.
dnl This should be the last --with option, because --with-x is
dnl added later on when we find the path of X, and it's best to
dnl keep them together visually.
@@ -122,19 +123,24 @@ this option's value should be `yes', `no', `lucid', `athena', `motif' or `gtk'.
with_x_toolkit=$val
])
-OPTION_DEFAULT_OFF([xpm],[use -lXpm for displaying XPM images])
-OPTION_DEFAULT_OFF([jpeg],[use -ljpeg for displaying JPEG images])
-OPTION_DEFAULT_OFF([tiff],[use -ltiff for displaying TIFF images])
-OPTION_DEFAULT_OFF([gif],[use -lgif (or -lungif) for displaying GIF images])
-OPTION_DEFAULT_OFF([png],[use -lpng for displaying PNG images])
-OPTION_DEFAULT_OFF([gpm],[use -lgpm for mouse support on a GNU/Linux console])
-OPTION_DEFAULT_OFF([rsvg],[use -lrsvg-2 for displaying SVG images])
-OPTION_DEFAULT_OFF([gtk],[use GTK (same as --with-x-toolkit=gtk)])
+dnl _ON results in a '--without' option in the --help output, so
+dnl the help text should refer to "don't compile", etc.
+OPTION_DEFAULT_ON([xpm],[don't compile with XPM image support])
+OPTION_DEFAULT_ON([jpeg],[don't compile with JPEG image support])
+OPTION_DEFAULT_ON([tiff],[don't compile with TIFF image support])
+OPTION_DEFAULT_ON([gif],[don't compile with GIF image support])
+OPTION_DEFAULT_ON([png],[don't compile with PNG image support])
+OPTION_DEFAULT_ON([rsvg],[don't compile with SVG image support])
+
+OPTION_DEFAULT_OFF([gtk],[use GTK toolkit])
OPTION_DEFAULT_ON([toolkit-scroll-bars],[don't use Motif or Xaw3d scroll bars])
OPTION_DEFAULT_ON([xaw3d],[don't use Xaw3d])
OPTION_DEFAULT_ON([xim],[don't use X11 XIM])
-OPTION_DEFAULT_ON([carbon],[don't use Carbon GUI on Mac OS X])
-OPTION_DEFAULT_ON([dbus],[use D-Bus])
+OPTION_DEFAULT_OFF([carbon],[use Carbon GUI on Mac OS X. **UNSUPPORTED!**])
+
+OPTION_DEFAULT_ON([gpm],[don't use -lgpm for mouse support on a GNU/Linux console])
+OPTION_DEFAULT_OFF([dbus],[compile with D-Bus support])
+
AC_ARG_WITH([pkg-config-prog],dnl
[AS_HELP_STRING([--with-pkg-config-prog=PATH],