aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDan Nicolaescu <[email protected]>2010-11-13 12:22:52 -0500
committerChong Yidong <[email protected]>2010-11-13 12:22:52 -0500
commit4d613e98a7ca89dbebbcc1a2865f8df04bf888f8 (patch)
treeb5abd818b623806a41023f2c549c24b17ca343b9 /configure.in
parentcdf015b1880d94bc414188ec5980171adc48bed2 (diff)
Backport fix for Bug#6170 from trunk.
Fix alloca definition when using gcc on non-gnu systems. * configure.in: Use the code sequence indicated by "info autoconf" for alloca (bug#6170).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 13 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index ca68db1b83..b9e183cad3 100644
--- a/configure.in
+++ b/configure.in
@@ -2927,15 +2927,19 @@ extern char *getenv ();
#ifdef HAVE_STDLIB_H
#include <stdlib.h>
#endif
-#ifndef __GNUC__
-# ifdef HAVE_ALLOCA_H
-# include <alloca.h>
-# else /* AIX files deal with #pragma. */
-# ifndef alloca /* predefined by HP cc +Olibcalls */
-char *alloca ();
-# endif
-# endif /* HAVE_ALLOCA_H */
-#endif /* __GNUC__ */
+#ifdef HAVE_ALLOCA_H
+# include <alloca.h>
+#elif defined __GNUC__
+# define alloca __builtin_alloca
+#elif defined _AIX
+# define alloca __alloca
+#else
+# include <stddef.h>
+# ifdef __cplusplus
+extern "C"
+# endif
+void *alloca (size_t);
+#endif
#ifndef HAVE_SIZE_T
typedef unsigned size_t;
#endif