aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <[email protected]>2008-03-05 03:53:49 +0000
committerGlenn Morris <[email protected]>2008-03-05 03:53:49 +0000
commit491d33f986ccba33c3345a87082b46f536e39b16 (patch)
tree120768cd4e8ddfae0007166e36d584a3a45177e5 /configure.in
parent2bde7652cdeeca9a19f57df7e824a014c875ab35 (diff)
Enable font-backend by default.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 0ad8e3ffb6..0c4ab12ca8 100644
--- a/configure.in
+++ b/configure.in
@@ -167,10 +167,11 @@ AC_ARG_ENABLE(carbon-app,
[DIR=/Application]])],
[ carbon_appdir_x=${enableval}])
+## Enabled by default.
AC_ARG_ENABLE(font-backend,
-[ --enable-font-backend compile code of font-backend support],
+[AS_HELP_STRING([--disable-font-backend],[don't compile font-backend support])],
USE_FONT_BACKEND=$enableval,
- USE_FONT_BACKEND=no)
+ USE_FONT_BACKEND=yes)
AC_ARG_ENABLE(asserts,
[AS_HELP_STRING([--enable-asserts], [compile code with asserts enabled])],
@@ -1949,7 +1950,7 @@ either XPointer or XPointer*.])dnl
fi
#### For font-backend
-if test "${USE_FONT_BACKEND}" = "yes"; then
+if test "${USE_FONT_BACKEND}" != "no"; then
AC_DEFINE(USE_FONT_BACKEND, 1,
[Define to 1 if we should use font-backend.])