aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDan Nicolaescu <[email protected]>2008-02-25 08:17:18 +0000
committerDan Nicolaescu <[email protected]>2008-02-25 08:17:18 +0000
commit26a42dac08a51b4618cd841df8c01f025aa749f5 (patch)
treefc8f1795452821bdecc47a230f8a4bc8284824ed /configure.in
parente46e905ae3b3d7a5d2708e6090dca70fe7a604f0 (diff)
* configure.in: Print an error for systems that we think are
obsolete and are proposed to be removed. Remove some more unused systems. * configure: Regenerate.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 27 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 7c34beae8b..bbb133e4bd 100644
--- a/configure.in
+++ b/configure.in
@@ -343,7 +343,6 @@ dnl see the `changequote' comment above.
hppa-*-openbsd*) machine=hp9000s300 ;;
i386-*-openbsd*) machine=intel386 ;;
m68k-*-openbsd*) machine=hp9000s300 ;;
- mips64-*-openbsd*) machine=mips64 ;;
powerpc-*-openbsd*) machine=macppc ;;
sparc*-*-openbsd*) machine=sparc ;;
vax-*-openbsd*) machine=vax ;;
@@ -403,11 +402,6 @@ dnl see the `changequote' comment above.
fi
;;
- ## Compaq Nonstop
- mips-compaq-nonstopux* )
- machine=nonstopux opsys=nonstopux
- ;;
-
## Cubix QBx/386
i[3456]86-cubix-sysv* )
machine=intel386 opsys=usg5-3
@@ -511,6 +505,9 @@ dnl see the `changequote' comment above.
rs6000-ibm-aix5* | powerpc-ibm-aix5* )
machine=ibmrs6000 opsys=aix4-2
;;
+ rs6000-ibm-aix5* | powerpc-ibm-aix6* )
+ machine=ibmrs6000 opsys=aix4-2
+ ;;
rs6000-ibm-aix4.0* | powerpc-ibm-aix4.0* )
machine=ibmrs6000 opsys=aix4
;;
@@ -752,6 +749,30 @@ if test x"${opsys}" = x; then
esac
fi
+### Tests for sytems that we beleive are obsolete and should be desupported.
+
+case "${machine}" in
+ pmax | hp9000s300 | ibm370aix | ncr386 | ews4800 | mips-siemens | powerpcle | tandem-s2 )
+ echo "The system that you are configuring on: ${canonical} is considered to be obsolete"
+ echo "and it is planned to be desupported in the next version of Emacs"
+ echo "Please email [email protected] as soon as possible if this system is still in use."
+ echo "The code is still functional, but you need to edit the 'configure' script and remove the"
+ echo "exit 33 line. After that you can run configure again and 'complete' the build."
+ exit 33
+ ;;
+esac
+
+case "${opsys}" in
+ bsd386 | bsdos2-1 | bsdos2 | bsdos3 | bsdos4 | bsd4-1 | bsd4-2 | bsd4-3 | usg5-0 | usg5-2-2 | usg5-2 | usg5-3 | ultrix4-3 | 386bsd | hpux | hpux8 | hpux9 | hpux9shr | hpux10 | hpux10-20 | aix3-1 | aix3-2-5 | aix3-2 | aix4-1 | nextstep | ux4800 | uxpds | uxpv )
+ echo "The system that you are configuring on: ${canonical} is considered to be obsolete"
+ echo "and it is planned to be desupported in the next version of Emacs"
+ echo "Please email [email protected] as soon as possible if this system is still in use."
+ echo "The code is still functional, but you need to edit the 'configure' script and remove the"
+ echo "'exit 44' line. After that you can run 'configure' again and complete the build."
+ exit 44
+ ;;
+esac
+
]
dnl quotation ends