aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDave Love <[email protected]>2000-06-21 14:08:44 +0000
committerDave Love <[email protected]>2000-06-21 14:08:44 +0000
commit1ca2077a457176ed20a2487b6238c02e4edf7284 (patch)
tree087e182bf77c00dae4a30f55c40c569b731f33cf /configure.in
parent98c6d6edf3079412dd7649a0d9ea3074c40e162d (diff)
Check for fcntl.h. Use AC_FUNC_GETLOADAVG, not simple test for
getloadavg and substitute GETLOADAVG_LIBS. Simplify test for GETTIMEOFDAY_ONE_ARGUMENT.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 7 insertions, 23 deletions
diff --git a/configure.in b/configure.in
index 91700caaf8..32decf1fbe 100644
--- a/configure.in
+++ b/configure.in
@@ -1158,7 +1158,7 @@ AC_CHECK_HEADERS(machine/soundcard.h sys/soundcard.h)
dnl checks for header files
AC_CHECK_HEADERS(sys/select.h sys/timeb.h sys/time.h unistd.h utime.h \
linux/version.h sys/systeminfo.h termios.h limits.h string.h stdlib.h \
- termcap.h stdio_ext.h)
+ termcap.h stdio_ext.h fcntl.h)
AC_HEADER_STDC
AC_HEADER_TIME
AC_DECL_SYS_SIGLIST
@@ -1868,13 +1868,15 @@ rename closedir mkdir rmdir sysinfo \
random lrand48 bcopy bcmp logb frexp fmod rint cbrt ftime res_init setsid \
strerror fpathconf select mktime euidaccess getpagesize tzset setlocale \
utimes setrlimit setpgid getcwd getwd shutdown strftime getaddrinfo \
-__fpending getloadavg mblen mbrlen strsignal setitimer ualarm)
+__fpending mblen mbrlen strsignal setitimer ualarm)
AC_FUNC_MKTIME
if test "$ac_cv_func_working_mktime" = no; then
AC_DEFINE(BROKEN_MKTIME)
fi
+AC_FUNC_GETLOADAVG
+
AC_SYS_LARGEFILE
AC_CHECK_FUNCS(ftello)
@@ -1980,28 +1982,9 @@ AC_TRY_LINK([
#endif
#endif],
[struct timeval time;
- struct timezone dummy;
- gettimeofday (&time, &dummy);],
+ gettimeofday (&time, 0);],
emacs_cv_gettimeofday_two_arguments=yes,
-dnl The above test loses, e.g. on OSF 5.0 with _XOPEN_SOURCE defined by
-dnl AC_SYS_LARGEFILE, because struct timezone is hidden.
-dnl Try again assuming a void * second arg.
- AC_TRY_LINK([
-#ifdef TIME_WITH_SYS_TIME
-#include <sys/time.h>
-#include <time.h>
-#else
-#ifdef HAVE_SYS_TIME_H
-#include <sys/time.h>
-#else
-#include <time.h>
-#endif
-#endif],
- [struct timeval time;
- int dummy;
- gettimeofday (&time, &dummy);],
- emacs_cv_gettimeofday_two_arguments=yes,
- emacs_cv_gettimeofday_two_arguments=no)))
+ emacs_cv_gettimeofday_two_arguments=no))
if test $emacs_cv_gettimeofday_two_arguments = no; then
AC_DEFINE(GETTIMEOFDAY_ONE_ARGUMENT)
fi
@@ -2076,6 +2059,7 @@ AC_SUBST(CFLAGS)
AC_SUBST(X_TOOLKIT_TYPE)
AC_SUBST(machfile)
AC_SUBST(opsysfile)
+AC_SUBST(GETLOADAVG_LIBS)
AC_DEFINE_UNQUOTED(EMACS_CONFIGURATION, "${canonical}")
AC_DEFINE_UNQUOTED(EMACS_CONFIG_OPTIONS, "${ac_configure_args}")