aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <[email protected]>2014-06-10 12:43:13 -0700
committerPaul Eggert <[email protected]>2014-06-10 12:43:13 -0700
commitec4a33476e4aa6eba3a13fca34ad157fec3d8b97 (patch)
tree12f237833701996dd3f45f5e25f4a0725119fa94 /configure.ac
parentbd009aefd54cf87c3b4eb91c29371745b5915ea1 (diff)
Rely on AC_CANONICAL_HOST to detect whether we're using mingw.
See the thread containing: http://lists.gnu.org/archive/html/emacs-devel/2014-06/msg00206.html * configure.ac (AC_CANONICAL_HOST): Invoke this as early as we can, which is just after AM_INIT_AUTOMAKE. Then check for mingw just after that.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 21 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 084dccc0dc..4b1e2a057e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,22 +25,6 @@ AC_PREREQ(2.65)
dnl Note this is parsed by (at least) make-dist and lisp/cedet/ede/emacs.el.
AC_INIT(GNU Emacs, 24.4.50, [email protected])
-dnl We get MINGW64 with MSYS2
-if test "x$MSYSTEM" = "xMINGW32" -o "x$MSYSTEM" = "xMINGW64"
-then
- . $srcdir/nt/mingw-cfg.site
-
- case $srcdir in
- /* | ?:*)
- # srcdir is an absolute path. In this case, force the format
- # "/c/foo/bar", to simplify later conversions to native Windows
- # format ("c:/foo/bar")
- srcdir=`cd "${srcdir}" && pwd -W`
- srcdir="/${srcdir:0:1}${srcdir:2}"
- ;;
- esac
-fi
-
dnl Set emacs_config_options to the options of 'configure', quoted for the shell,
dnl and then quoted again for a C string. Separate options with spaces.
dnl Add some environment variables, if they were passed via the environment
@@ -146,6 +130,27 @@ MAKE=$ac_cv_path_MAKE
dnl Fairly arbitrary, older versions might work too.
AM_INIT_AUTOMAKE(1.11)
+dnl Canonicalize the configuration name.
+AC_CANONICAL_HOST
+canonical=$host
+configuration=${host_alias-${build_alias-$host}}
+
+dnl We get MINGW64 with MSYS2.
+case $canonical in
+ *-mingw*)
+ . $srcdir/nt/mingw-cfg.site
+
+ case $srcdir in
+ /* | ?:*)
+ # srcdir is an absolute path. In this case, force the format
+ # "/c/foo/bar", to simplify later conversions to native Windows
+ # format ("c:/foo/bar").
+ srcdir=`cd "${srcdir}" && pwd -W`
+ srcdir="/${srcdir:0:1}${srcdir:2}"
+ ;;
+ esac;;
+esac
+
dnl Support for --program-prefix, --program-suffix and
dnl --program-transform-name options
AC_ARG_PROGRAM
@@ -489,12 +494,6 @@ AC_ARG_ENABLE(gtk-deprecation-warnings,
[Show Gtk+/Gdk deprecation warnings for Gtk+ >= 3.0])],
[ac_enable_gtk_deprecation_warnings="${enableval}"],[])
-### Canonicalize the configuration name.
-
-AC_CANONICAL_HOST
-canonical=$host
-configuration=${host_alias-${build_alias-$host}}
-
dnl This used to use changequote, but, apart from `changequote is evil'
dnl per the autoconf manual, we can speed up autoconf somewhat by quoting
dnl the great gob of text. Thus it's not processed for possible expansion.