aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBT Templeton <[email protected]>2012-05-31 01:54:25 -0400
committerRobin Templeton <[email protected]>2015-02-09 13:04:17 -0500
commite8396880813faf3a54b8576d259c785ce4276a1f (patch)
tree36001675edc23b51c948f0beb78c9e1d33df30eb /configure.ac
parentffcb9420e221f65bcdbadf63fde0f478fd7258ff (diff)
libgc configuration
* configure.in (BDW_GC_CFLAGS, BDW_GC_LIBS): New variables. * src/Makefile.in (CFLAGS): Add BDW_GC_CFLAGS. (LIBES): Add BDW_GC_LIBS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 04c75e30df..e21ad47a0e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1432,7 +1432,14 @@ AC_DEFUN([EMACS_CHECK_MODULES],
m4_default([$3], [HAVE_$1=yes])],
[m4_default([$4], [HAVE_$1=no])])])
+PKG_CHECK_MODULES([BDW_GC], [bdw-gc])
+AC_SUBST(BDW_GC_CFLAGS)
+AC_SUBST(BDW_GC_LIBS)
+CFLAGS="$CFLAGS $BDW_GC_CFLAGS"
+LIBS="$BDW_GC_LIBS $LIBS"
+
HAVE_SOUND=no
+
if test "${with_sound}" != "no"; then
# Sound support for GNU/Linux, the free BSDs, and MinGW.
AC_CHECK_HEADERS([machine/soundcard.h sys/soundcard.h soundcard.h],