aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Morris <[email protected]>2014-06-14 17:06:30 -0700
committerGlenn Morris <[email protected]>2014-06-14 17:06:30 -0700
commit90de50e27049ae19492dd9843e50618ea4ed5d14 (patch)
tree1efdf48fb6243e3f8448465c59dda3eb9db67a0c /configure.ac
parent799d2f3d87185a51835d0594a89485932d0f4c23 (diff)
parent27433ff85f21f108e84a6e8966c9461cf66c2015 (diff)
Merge from emacs-24; up to 2014-06-03T06:51:[email protected]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 9 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 0f7d858bd6..c24469a0bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2091,11 +2091,15 @@ if test "$ac_cv_header_pthread_h"; then
# Some systems optimize for single-threaded programs by default, and
# need special flags to disable these optimizations. For example, the
# definition of 'errno' in <errno.h>.
- if test "$opsys" = aix4-2; then
- AC_DEFINE([_THREAD_SAFE], [1],
- [Define to 1 if your system requires this in multithreaded code.])
- fi])
- if test "X$LIBS" != "X$OLD_LIBS"; then
+ case $opsys in
+ sol*)
+ AC_DEFINE([_REENTRANT], 1,
+ [Define to 1 if your system requires this in multithreaded code.]);;
+ aix4-2)
+ AC_DEFINE([_THREAD_SAFE], 1,
+ [Define to 1 if your system requires this in multithreaded code.]);;
+ esac])
+ if test "X$LIBS" != "X$OLD_LIBS"; then
eval LIB_PTHREAD=\$ac_cv_search_$emacs_pthread_function
fi
LIBS=$OLD_LIBS