aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Zaretskii <[email protected]>2014-06-03 10:28:07 +0300
committerEli Zaretskii <[email protected]>2014-06-03 10:28:07 +0300
commit89b362029282eff2b709e3a64e8e4ec3bc673676 (patch)
tree8e76bb48f6720e0be50d0fa33054081c5be5d631 /configure.ac
parent0031c9530d24fb25d8bdcadaf7457b7dee51da0c (diff)
Define the size of dumped data for MS-Windows locally on w32heap.c.
configure.ac (C_HEAP_SWITCH): Remove. src/w32heap.c (DUMPED_HEAP_SIZE): Move from w32heap.h. Don't use HEAPSIZE; instead, define separate values for the 32- and 64-bit builds. src/Makefile.in (C_HEAP_SWITCH): Remove. (ALL_CFLAGS): Don't use $(C_HEAP_SWITCH).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 48eda74a06..967d2c4470 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4835,18 +4835,6 @@ LD_SWITCH_SYSTEM_TEMACS="$LDFLAGS_NOCOMBRELOC $LD_SWITCH_SYSTEM_TEMACS"
AC_SUBST(LD_SWITCH_SYSTEM_TEMACS)
-## MinGW-specific compilation switch.
-C_HEAP_SWITCH=
-if test "${opsys}" = "mingw32"; then
- ## Preload heap size of temacs.exe in MB.
- case "$canonical" in
- x86_64-*-*) C_HEAP_SWITCH="-DHEAPSIZE=18" ;;
- *) C_HEAP_SWITCH="-DHEAPSIZE=12" ;;
- esac
-fi
-
-AC_SUBST(C_HEAP_SWITCH)
-
## Common for all window systems
if test "$window_system" != "none"; then
AC_DEFINE(HAVE_WINDOW_SYSTEM, 1, [Define if you have a window system.])