aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <[email protected]>2014-06-20 09:05:10 -0700
committerPaul Eggert <[email protected]>2014-06-20 09:05:10 -0700
commit539ad293eb36b4cf458cbdb5a6b37f5cd1bb68a1 (patch)
tree1a0840c2a54e6d39b1a5541c1ff7fa763ead4182 /configure.ac
parentcb5f7e19f2e71dec8cae189c7233f31610d543aa (diff)
Diagnose failures due to colons in directory names.
* Makefile.in (epaths-force): Don't allow ':' in directories whose names go into a colon-separated path. * configure.ac: Fail if submake fails. Fixes: debbugs:17278
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 56005b51e2..c4ca395d6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5121,7 +5121,7 @@ if test "${opsys}" = "mingw32"; then
${MAKE-make} MAKEFILE_NAME=do-not-make-Makefile epaths-force-w32
else
${MAKE-make} MAKEFILE_NAME=do-not-make-Makefile epaths-force
-fi
+fi || AC_MSG_ERROR(['src/epaths.h' could not be made.])
], [GCC="$GCC" CPPFLAGS="$CPPFLAGS" opsys="$opsys"])
dnl NB we have to cheat and use the ac_... version because abs_top_srcdir