aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <[email protected]>2014-06-04 17:34:34 -0700
committerPaul Eggert <[email protected]>2014-06-04 17:34:34 -0700
commit444060a55d4d6fb55a9c0fd4d22c09ef757b38d7 (patch)
tree2a9246b953f1599164e9517659990fc1636503a7 /configure.ac
parentb1b4013662078e4134d32214aa2584610b65e29b (diff)
* configure.ac: --without-all now implies --without-xft, --disable-acl.
* INSTALL: Remove apparently unmaintained documentation about what --without-all exactly means.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 15 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 967d2c4470..fbfedb0279 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2817,14 +2817,17 @@ fi
### Start of font-backend (under X11) section.
if test "${HAVE_X11}" = "yes"; then
- EMACS_CHECK_MODULES([FONTCONFIG], [fontconfig >= 2.2.0],
- [HAVE_FC=yes], [HAVE_FC=no])
-
- ## Use -lXft if available, unless `--with-xft=no'.
- HAVE_XFT=maybe
- if test "${HAVE_FC}" = "no" || test "x${with_x}" = "xno"; then
+ ## Use -lXft if available, unless `--with-xft=no'.
+ HAVE_XFT=maybe
+ if test "x${with_x}" = "xno"; then
with_xft="no";
fi
+
+ if test "$with_xft" != no; then
+ EMACS_CHECK_MODULES([FONTCONFIG], [fontconfig >= 2.2.0])
+ with_xft=$HAVE_FONTCONFIG
+ fi
+
if test "x${with_xft}" != "xno"; then
EMACS_CHECK_MODULES([XFT], [xft >= 0.13.0], [], [HAVE_XFT=no])
@@ -4751,6 +4754,12 @@ AH_VERBATIM([FORTIFY_SOUR],
#endif
])
+# If user asks to omit features, disable optional features that gnulib
+# might otherwise enable.
+if test "$with_features" = no && test "$enable_acl" != yes; then
+ enable_acl=no
+fi
+
# Configure gnulib. Although this does not affect CFLAGS or LIBS permanently.
# it temporarily reverts them to their pre-pkg-config values,
# because gnulib needs to work with both src (which uses the