aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Djärv <[email protected]>2014-05-15 18:54:44 +0200
committerJan Djärv <[email protected]>2014-05-15 18:54:44 +0200
commit440cef5fc5147af9d49396b8828721676e312658 (patch)
treea60584f608a3ca80b106a92f2620570da13790f3 /configure.ac
parentddc30c996a3d14e0163df6946ba96c9bcf73bd2f (diff)
Fix yet another configure error on OSX.
* configure.ac (LIBONG): Do not test for libpng if NS_IMPL_COCOA.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bb1bdd84b2..5e30c49f2d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3070,7 +3070,9 @@ AC_SUBST(LIBZ)
HAVE_PNG=no
LIBPNG=
PNG_CFLAGS=
-if test "${with_png}" != no; then
+if test "${NS_IMPL_COCOA}" = yes; then
+ : # Nothing to do
+elif test "${with_png}" != no; then
# mingw32 loads the library dynamically.
if test "$opsys" = mingw32; then
AC_CHECK_HEADER([png.h], [HAVE_PNG=yes])