summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm18
-rw-r--r--gnu/packages/gstreamer.scm2
2 files changed, 3 insertions, 17 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 79aeec4ffc..3195a3762c 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1063,7 +1063,7 @@ useful for C++.")
(define-public python-pygobject
(package
(name "python-pygobject")
- (version "3.47.0")
+ (version "3.50.0")
(source
(origin
(method url-fetch)
@@ -1072,7 +1072,7 @@ useful for C++.")
"/pygobject-" version ".tar.xz"))
(sha256
(base32
- "082dpm34a350bnhgmkdv8myxzjgnrflckkpn46vnvs36f7bbfdij"))
+ "04i28xrb9fxkmn9j2mmsl0lbmk9blgjcl8hnxrbx90d8nmsnx0wd"))
(modules '((guix build utils)))
(snippet
;; We disable these tests in a snippet so that they are inherited
@@ -1112,20 +1112,6 @@ useful for C++.")
'((upstream-name . "pygobject")))
(license license:lgpl2.1+)))
-(define-public python-pygobject-3.48
- (package
- (inherit python-pygobject)
- (version "3.48.2")
- (source
- (origin
- (inherit (package-source python-pygobject))
- (uri (string-append "mirror://gnome/sources/pygobject/"
- (version-major+minor version)
- "/pygobject-" version ".tar.xz"))
- (sha256
- (base32
- "19yii8lydnjw225k4gclhn8hya7caiginqi0mj9a0cdym6sax507"))))))
-
(define-public perl-glib
(package
(name "perl-glib")
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 576333e6e1..e06ab79b7c 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -1130,7 +1130,7 @@ binary, but none of the actual plugins.")))
(native-inputs
(list pkg-config python))
(propagated-inputs
- (list gst-plugins-base python-pygobject-3.48))
+ (list gst-plugins-base python-pygobject))
(home-page "https://gstreamer.freedesktop.org/")
(synopsis "GStreamer GObject Introspection overrides for Python")
(description