summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm29
-rw-r--r--gnu/packages/golang-xyz.scm28
2 files changed, 29 insertions, 28 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index b9ffbdc9c0..e94bdce1f0 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -6911,6 +6911,35 @@ on @@url{https://github.com/quic-go/quic-go,quic-go}. It currently implements
of the specification.")
(license license:expat)))
+(define-public go-github-com-rcrowley-go-metrics
+ (package
+ (name "go-github-com-rcrowley-go-metrics")
+ (version "0.0.0-20201227073835-cf1acfcdf475")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rcrowley/go-metrics")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s7zab04slz07c7l4h2cqz62qnqah69r6p157vvbd7725a7wzkr0"))))
+ (build-system go-build-system)
+ (arguments
+ ;; Arbitrary precision tests are known to be broken on aarch64, ppc64le
+ ;; and s390x. See: https://github.com/rcrowley/go-metrics/issues/249
+ `(#:tests? ,(not (string-prefix? "aarch64" (or (%current-target-system)
+ (%current-system))))
+ #:import-path "github.com/rcrowley/go-metrics"))
+ (propagated-inputs
+ (list go-github-com-stathat-go))
+ (home-page "https://github.com/rcrowley/go-metrics")
+ (synopsis "Go port of Coda Hale's Metrics library")
+ (description
+ "This package provides a Go implementation of Coda Hale's Metrics
+library.")
+ (license license:bsd-2)))
+
(define-public go-github-com-rs-cors
(package
(name "go-github-com-rs-cors")
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7f71d728af..c2ca350a12 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -11830,34 +11830,6 @@ watches memory utilization and forces Go GC in accordance with a user-defined
policy.")
(license (list license:asl2.0 license:expat))))
-(define-public go-github-com-rcrowley-go-metrics
- (package
- (name "go-github-com-rcrowley-go-metrics")
- (version "0.0.0-20201227073835-cf1acfcdf475")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rcrowley/go-metrics")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0s7zab04slz07c7l4h2cqz62qnqah69r6p157vvbd7725a7wzkr0"))))
- (build-system go-build-system)
- (arguments
- ;; Arbitrary precision tests are known to be broken on aarch64, ppc64le
- ;; and s390x. See: https://github.com/rcrowley/go-metrics/issues/249
- `(#:tests? ,(not (string-prefix? "aarch64" (or (%current-target-system)
- (%current-system))))
- #:import-path "github.com/rcrowley/go-metrics"))
- (propagated-inputs
- (list go-github-com-stathat-go))
- (synopsis "Go port of Coda Hale's Metrics library")
- (description "This package provides a Go implementation of Coda Hale's
-Metrics library.")
- (home-page "https://github.com/rcrowley/go-metrics")
- (license license:bsd-2)))
-
(define-public go-github-com-remeh-sizedwaitgroup
(package
(name "go-github-com-remeh-sizedwaitgroup")