summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-aionotify-0.2.0-py3.8.patch48
-rw-r--r--gnu/packages/python-xyz.scm13
3 files changed, 6 insertions, 56 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 20cfa4b7d2..70a34685e9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2043,7 +2043,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-3-hurd-configure.patch \
%D%/packages/patches/python-angr-check-exec-deps.patch \
%D%/packages/patches/python-3-reproducible-build.patch \
- %D%/packages/patches/python-aionotify-0.2.0-py3.8.patch \
%D%/packages/patches/python-cross-compile.patch \
%D%/packages/patches/python-configobj-setuptools.patch \
%D%/packages/patches/python-dateutil-pytest-compat.patch \
diff --git a/gnu/packages/patches/python-aionotify-0.2.0-py3.8.patch b/gnu/packages/patches/python-aionotify-0.2.0-py3.8.patch
deleted file mode 100644
index ebeef34720..0000000000
--- a/gnu/packages/patches/python-aionotify-0.2.0-py3.8.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-Compatibility with Python 3.8, see upstream issue
-https://github.com/rbarrois/aionotify/pull/15
-
-diff --git a/setup.py b/setup.py
-index 21a554f..094de64 100755
---- a/setup.py
-+++ b/setup.py
-@@ -40,7 +40,7 @@ setup(
- setup_requires=[
- ],
- tests_require=[
-- 'asynctest',
-+ 'asynctest; python_version<"3.8"',
- ],
- classifiers=[
- "Development Status :: 4 - Beta",
-diff --git a/tests/test_usage.py b/tests/test_usage.py
-index f156291..0476ff1 100644
---- a/tests/test_usage.py
-+++ b/tests/test_usage.py
-@@ -8,7 +8,11 @@ import os.path
- import tempfile
- import unittest
-
--import asynctest
-+try:
-+ testBase = unittest.IsolatedAsyncioTestCase
-+except AttributeError:
-+ import asynctest
-+ testBase = asynctest.TestCase
-
- import aionotify
-
-@@ -25,11 +29,13 @@ if AIODEBUG:
- TESTDIR = os.environ.get('AIOTESTDIR') or os.path.join(os.path.dirname(__file__), 'testevents')
-
-
--class AIONotifyTestCase(asynctest.TestCase):
-+class AIONotifyTestCase(testBase):
- forbid_get_event_loop = True
- timeout = 3
-
- def setUp(self):
-+ if not getattr (self, 'loop', None):
-+ self.loop = asyncio.get_event_loop()
- if AIODEBUG:
- self.loop.set_debug(True)
- self.watcher = aionotify.Watcher()
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1294368ef1..f9230847a0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31377,23 +31377,22 @@ Notation (CSON).")
(define-public python-aionotify
(package
(name "python-aionotify")
- (version "0.2.0")
+ (version "0.3.0")
(source
(origin
;; Source tarball on PyPi lacks tests
(method git-fetch)
(uri (git-reference
(url "https://github.com/rbarrois/aionotify")
- (commit (string-append "v" version))))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1sk9i8czxgsbrswsf1nlb4c82vgnlzi8zrvrxdip92w2z8hqh43y"))
- (patches (search-patches "python-aionotify-0.2.0-py3.8.patch"))))
- (build-system python-build-system)
+ (base32 "0qkzwccv8k6mx1yvc0hmsgnzgb4vh8h97kq7i64ic6xzxkd57vkz"))))
+ (build-system pyproject-build-system)
(home-page "https://github.com/rbarrois/aionotify")
- (synopsis "Asyncio-powered inotify library")
+ (synopsis "inotify library for Python")
(description
- "@code{aionotify} is a simple, asyncio-based inotify library.")
+ "@code{python-aionotify} is a simple, asyncio-based inotify library.")
(license license:bsd-3)))
(define-public python-forbiddenfruit