summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm51
1 files changed, 6 insertions, 45 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e6a4acb731..c00a54066b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22730,57 +22730,18 @@ objects, patterned after the Mocha library for Ruby.")
(define-public python-inflect
(package
(name "python-inflect")
- (version "6.0.4")
+ (version "7.5.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "inflect" version))
(sha256
(base32
- "1sqj4svg2vbn4vq332nxnvky2433rgxbvjd529lddjmn2yd68hhq"))))
+ "07spmlkmskwhxc0j5j4ms3w0f6pyv3h8iqwcbahdabklqc0riwgs"))))
(build-system pyproject-build-system)
- (arguments
- (list
- #:test-flags
- '(list "--ignore=_custom_build/backend.py"
- "-k" "not mypy-status")
- #:phases
- '(modify-phases %standard-phases
- ;; The build system insists on ignoring the existing environment and
- ;; running "pip install".
- (add-after 'unpack 'do-not-use-pip-install
- (lambda _
- (substitute* "pyproject.toml"
- (("^build-backend.*") "\
-build-backend = \"backend\"
-backend_path = [\"_custom_build\"]\n")
- (("requires = .*") "requires = []\n"))
- (mkdir-p "_custom_build")
- (with-output-to-file "_custom_build/backend.py"
- (lambda _
- (display "\
-from setuptools import build_meta as _orig
-from setuptools.build_meta import *
-def get_requires_for_build_wheel(config_settings=None):
- return []
-def get_requires_for_build_sdist(config_settings=None):
- return []
-")))
- (setenv "PYTHONPATH"
- (string-append (getcwd) "/_custom_build")))))))
- (propagated-inputs (list python-pydantic))
- (native-inputs (list python-flake8
- python-pygments
- python-pytest
- python-pytest-black
- python-pytest-checkdocs
- python-pytest-cov
- python-pytest-enabler
- python-pytest-flake8
- python-pytest-mypy
- ;; For the version number
- python-setuptools-scm
- python-setuptools
- python-wheel))
+ (propagated-inputs (list python-more-itertools python-typeguard
+ python-typing-extensions))
+ (native-inputs (list python-pygments python-pytest python-setuptools
+ python-setuptools-scm python-wheel))
(home-page "https://github.com/jaraco/inflect")
(synopsis "Correctly generate plurals, singular nouns, ordinals, indefinite articles")
(description