summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a23dfe9ae6..3d269cea83 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015, 2016 Federico Beffa <[email protected]>
;;; Copyright © 2015 Siniša Biđin <[email protected]>
;;; Copyright © 2015 Paul van der Walt <[email protected]>
-;;; Copyright © 2015 Eric Bavier <[email protected]>
+;;; Copyright © 2015, 2019 Eric Bavier <[email protected]>
;;; Copyright © 2016, 2018, 2019 Ludovic Courtès <[email protected]>
;;; Copyright © 2016, 2017 ng0 <[email protected]>
;;; Copyright © 2016 Efraim Flashner <[email protected]>
@@ -833,6 +833,28 @@ code pages on Windows. On all other operating systems, the library does
nothing.")
(license license:bsd-3)))
+(define-public ghc-libffi
+ (package
+ (name "ghc-libffi")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "libffi/libffi-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0g7jnhng3j7z5517aaqga0144aamibsbpgm3yynwyfzkq1kp0f28"))))
+ (build-system haskell-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("libffi" ,libffi)))
+ (home-page "http://hackage.haskell.org/package/libffi")
+ (synopsis "Haskell binding to libffi")
+ (description
+ "A binding to libffi, allowing C functions of types only known at runtime
+to be called from Haskell.")
+ (license license:bsd-3)))
+
(define-public ghc-newtype-generics
(package
(name "ghc-newtype-generics")