summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 4ad555ef1b..a82db31e30 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Domagoj Stolfa <[email protected]>
;;; Copyright © 2021 Raghav Gururajan <[email protected]>
;;; Copyright © 2021 jgart <[email protected]>
+;;; Copyright © 2022 Josselin Poiret <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -382,7 +383,7 @@ endpoints.")
gmp
libcap
libgcrypt
- libsoup
+ libsoup-minimal-2
linux-pam
openssl))
(native-inputs
@@ -659,7 +660,7 @@ and probably others.")
python-lxml
python-prompt-toolkit
python-requests
- python-pyqt
+ python-pyqt-without-qtwebkit
python-pyqtwebengine
python-pysocks
python-pyxdg
@@ -753,7 +754,7 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
;; Wrap entrypoint with paths to its hard dependencies.
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((entrypoint (string-append (assoc-ref outputs "out")
- "/bin/.protonvpn-real")))
+ "/bin/protonvpn")))
(wrap-program entrypoint
#:sh (search-input-file inputs "bin/bash")
`("PATH" ":" prefix
@@ -768,7 +769,11 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
"openvpn"
"procps"
"which")))))
- #t)))))
+ #t))
+ ;; The `protonvpn' script wants to write to `~user' to initialize its
+ ;; logger, so simply setting HOME=/tmp won't cut it. Remove
+ ;; sanity-check.
+ (delete 'sanity-check))))
(native-inputs
(list python-docopt))
(inputs