summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm27
1 files changed, 17 insertions, 10 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 95287c7c69..93366a306c 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2017 Vasile Dumitrascu <[email protected]>
;;; Copyright © 2017 Clément Lassieur <[email protected]>
;;; Copyright © 2017, 2020 EuAndreh <[email protected]>
-;;; Copyright © 2017, 2018, 2020 Marius Bakke <[email protected]>
+;;; Copyright © 2017, 2018, 2020, 2022 Marius Bakke <[email protected]>
;;; Copyright © 2017 Stefan Reichör <[email protected]>
;;; Copyright © 2017, 2020 Oleg Pykhalov <[email protected]>
;;; Copyright © 2018 Sou Bunnbu <[email protected]>
@@ -29,7 +29,7 @@
;;; Copyright © 2020, 2021 Brice Waegeneire <[email protected]>
;;; Copyright © 2020 John D. Boy <[email protected]>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <[email protected]>
-;;; Copyright © 2020, 2021 Vinicius Monego <[email protected]>
+;;; Copyright © 2020, 2021, 2022 Vinicius Monego <[email protected]>
;;; Copyright © 2020 Tanguy Le Carrour <[email protected]>
;;; Copyright © 2020, 2021 Michael Rohleder <[email protected]>
;;; Copyright © 2021 Greg Hogan <[email protected]>
@@ -63,6 +63,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (guix packages)
+ #:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix hg-download)
@@ -1626,7 +1627,7 @@ visualize your public Git repositories on a web interface.")
(define-public pre-commit
(package
(name "pre-commit")
- (version "2.16.0")
+ (version "2.17.0")
(source
(origin
(method git-fetch) ; no tests in PyPI release
@@ -1635,7 +1636,7 @@ visualize your public Git repositories on a web interface.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1sf9mqpiv3pgzi6aar7xfna9v7n63lgm7d7b24fhni0jxn56384b"))))
+ (base32 "1y4h6zrypxgm9j8q66hcx5cs4q2dkh9schzn2nsdmdqad19356s9"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -2010,15 +2011,14 @@ projects, from individuals to large-scale enterprise operations.")
(define-public rcs
(package
(name "rcs")
- (version "5.10.0")
+ (version "5.10.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/rcs/rcs-"
- version ".tar.xz"))
+ version ".tar.lz"))
(sha256
(base32
- "1if5pa4iip2p70gljm54nggfdnsfjxa4cqz8fpj07lvsijary39s"))
- (patches (search-patches "rcs-5.10.0-no-stdin.patch"))))
+ "1iac4d1dhsfy5zb0n3p605pihdq702v06r4g8vi8b2saf88gxpa3"))))
(build-system gnu-build-system)
(arguments `(#:phases
(modify-phases %standard-phases
@@ -2030,7 +2030,7 @@ projects, from individuals to large-scale enterprise operations.")
(chmod "src/rcsfreeze" #o755)
(install-file "src/rcsfreeze" bin)
(install-file "man/rcsfreeze.1" man1)))))))
- (native-inputs (list ed))
+ (native-inputs (list ed lzip))
(home-page "https://www.gnu.org/software/rcs/")
(synopsis "Per-file local revision control system")
(description
@@ -2572,7 +2572,14 @@ based on a manifest file published by servers.")
(("~=") ">="))
#t))))
(build-system python-build-system)
- (arguments '(#:tests? #f)) ; No tests.
+ (arguments
+ (list #:tests? #f ;no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: dnspython attempts to read /etc/resolv.conf when loading
+ ;; resolver.py, which breaks the sanity check in dependent
+ ;; packages. This should rather be fixed in dnspython.
+ (delete 'sanity-check))))
(inputs
(list python-dkimpy python-dnspython python-requests))
(home-page "https://git.kernel.org/pub/scm/utils/b4/b4.git")