summaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 0d84dee178..2a94f53474 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2024 Sharlatan Hellseher <[email protected]>
;;; Copyright © 2024 Zheng Junjie <[email protected]>
;;; Copyright © 2024 Vinicius Monego <[email protected]>
+;;; Copyright © 2024 Ricardo Wurmus <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -439,17 +440,20 @@ under several distributions that's hard or impossible to figure out.")
(define-public python-isodate
(package
(name "python-isodate")
- (version "0.6.1")
+ (version "0.7.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "isodate" version))
(sha256
(base32
- "1sdx4z0x6kv1qxjfi0gd82wfg16wca04q0nb93ba1c78wwfqiia8"))))
- (build-system python-build-system)
+ "1rjkm5qj3lz60sgva5g38cpfqd8byj2jlaf0qskg8xna8c7smlac"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-six))
+ (list python-pytest
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://github.com/gweis/isodate/")
(synopsis "Python date parser and formatter")
(description