summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index c19cc97862..ebf7c2322e 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -46,9 +46,7 @@
(define-public syncthing
(package
(name "syncthing")
- (version "1.18.6")
- ; XXX After the go-build-system can use "Go modules", stop using bundled
- ; dependencies for Syncthing.
+ (version "1.19.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/syncthing/syncthing"
@@ -56,7 +54,7 @@
"/syncthing-source-v" version ".tar.gz"))
(sha256
(base32
- "0hlyk2nvsnf4am1vqc4zl91acf2rhpr1gy4gppk2aa5x85h9qisc"))))
+ "13b8dsvqgah13w5sfbwv1fpwj6sfqj2lv0d0x9433ljjq92lxkbg"))))
(build-system go-build-system)
;; The primary Syncthing executable goes to "out", while the auxiliary
;; server programs and utility tools go to "utils". This reduces the size
@@ -137,6 +135,9 @@
supports a wide variety of computing platforms. It uses the Block Exchange
Protocol.")
(home-page "https://github.com/syncthing/syncthing")
+ (properties
+ '((release-monitoring-url . "https://github.com/syncthing/syncthing/releases")
+ (upstream-name . "syncthing-source")))
(license mpl2.0)))
(define-public syncthing-gtk
@@ -217,6 +218,9 @@ notification area icon for Syncthing. Supported Syncthing features:
@end itemize\n")
(license gpl2))))
+(define-public qsyncthingtray
+ (deprecated-package "qsyncthingtray" syncthing-gtk))
+
(define-public go-github-com-jackpal-go-nat-pmp
(package
(name "go-github-com-jackpal-go-nat-pmp")