summaryrefslogtreecommitdiff
path: root/gnu/packages/swig.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/swig.scm')
-rw-r--r--gnu/packages/swig.scm26
1 files changed, 11 insertions, 15 deletions
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index b1b17fc68d..655c1a19ab 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013, 2015, 2016 Ludovic Courtès <[email protected]>
;;; Copyright © 2015 Mark H Weaver <[email protected]>
;;; Copyright © 2018 Marius Bakke <[email protected]>
+;;; Copyright © 2019 Efraim Flashner <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,11 +25,11 @@
#:use-module (guix licenses)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
- #:use-module (gnu packages pcre)
- #:use-module (gnu packages guile)
#:use-module (gnu packages boost)
- #:use-module (gnu packages python)
- #:use-module (gnu packages perl))
+ #:use-module (gnu packages guile)
+ #:use-module (gnu packages pcre)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages python))
(define-public swig
(package
@@ -60,17 +61,12 @@
(("-isystem ") "-I"))
#t)))))
(native-inputs `(("boost" ,boost)
- ("pcre" ,pcre "bin"))) ;for 'pcre-config'
- (inputs `(;; Provide these to run the corresponding tests.
- ("guile" ,guile-2.0)
- ("perl" ,perl)))
- ;; FIXME: reactivate input python as soon as the test failures
- ;; fatal error: Python.h: No such file or directory
- ;; # include <Python.h>
- ;; are fixed.
- ;; The python part probably never worked and does not seem to
- ;; be needed for currently dependent packages.
-;; ("python" ,python-wrapper)))
+ ("pcre" ,pcre "bin") ;for 'pcre-config'
+ ;; The following are for tests and examples:
+ ("guile" ,guile-2.0)
+ ("perl" ,perl)))
+ ;;("python" ,python-wrapper)
+ (inputs `(("pcre" ,pcre)))
(home-page "http://swig.org/")
(synopsis
"Interface compiler that connects C/C++ code to higher-level languages")