summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm22
1 files changed, 19 insertions, 3 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 2a01279161..6e2c4d4f78 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -187,7 +187,7 @@ external dependencies.")
(define-public samba
(package
(name "samba")
- (version "4.16.4")
+ (version "4.16.8")
(source
;; For updaters: the current PGP fingerprint is
;; 81F5E2832BD2545A1897B713AA99442FB680B620.
@@ -196,7 +196,7 @@ external dependencies.")
(uri (string-append "https://download.samba.org/pub/samba/stable/"
"samba-" version ".tar.gz"))
(sha256
- (base32 "0bvhqinxwpbwp4ayhd9q8ga0w89gnkl1m3nrwpj1fnhjzd4ghclm"))))
+ (base32 "11a1vikbijaq7csg49h5ivn25gx84v6wx8z8kgsj1wmkhsf9bcmv"))))
(build-system gnu-build-system)
(arguments
(list
@@ -295,7 +295,9 @@ Desktops into Active Directory environments using the winbind daemon.")
(define-public samba/fixed
;; Version that rarely changes, depended on by libsoup.
(hidden-package
- (package/inherit samba
+ (package
+ (inherit samba)
+ (replacement samba/fixed-patched)
(version "4.15.3")
(source
(origin
@@ -319,6 +321,20 @@ Desktops into Active Directory environments using the winbind daemon.")
libxslt
libxml2)))))
+(define-public samba/fixed-patched
+ (package
+ (inherit samba/fixed)
+ ;; This is 4.15.13, but we need to trim the store file name to have
+ ;; the same length as the one we are grafting above.
+ (version "4.15.A")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.samba.org/pub/samba/stable/"
+ "samba-4.15.13.tar.gz"))
+ (sha256
+ (base32 "0s29vzn5f42vjhx6h25c7v67n14ymqxn8glqa97d0rajd99y64n4"))))))
+
(define-public talloc
(package
(name "talloc")