summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index be6cae57bb..76c11af543 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2023 Simon South <[email protected]>
;;; Copyright © 2024 Foundation Devices, Inc. <[email protected]>
;;; Copyright © 2024 Josep Bigorra <[email protected]>
+;;; Copyright © 2025 John Kehayias <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5397,6 +5398,42 @@ also compatible with SGI and TGS Open Inventor, and the API is based on the API
of the InventorXt GUI component toolkit.")
(license license:bsd-3)))
+(define-public hyprland-qtutils
+ (package
+ (name "hyprland-qtutils")
+ (version "0.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hyprwm/hyprland-qtutils")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02ymf8xypnxhknb3d0bxbp96hargwrg9syb9xs3va3rmx909r7b6"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:tests? #f ;There are no tests.
+ #:qtbase qtbase))
+ (native-inputs (list gcc-14 pkg-config))
+ (inputs
+ (list bash-minimal
+ hyprutils
+ kirigami
+ libxkbcommon
+ qqc2-desktop-style
+ qtbase
+ qtdeclarative
+ qtwayland
+ wayland))
+ (home-page "https://github.com/hyprwm/hyprland-qtutils")
+ (synopsis "Hyprland QT/QML utility apps")
+ (description
+ "This package provides some QT/QML utilities that might be used by
+various hypr* apps.")
+ (license license:bsd-3)))
+
+
(define-public libdbusmenu-qt
(package
(name "libdbusmenu-qt")