summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 49d514503d..5a55c522af 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -146,14 +146,14 @@
(define-public qt5ct
(package
(name "qt5ct")
- (version "1.2")
+ (version "1.5")
(source
(origin
(method url-fetch)
(uri
(string-append "mirror://sourceforge/qt5ct/qt5ct-" version ".tar.bz2"))
(sha256
- (base32 "0bl7dc03b7vm435khkr932ybslsbq1nfajd936zlc1sxdmpg1qqx"))))
+ (base32 "14742vs32m98nbfb5mad0i8ciff5f45gfcb5v03p4hh2dvhhqgfn"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; No target
@@ -178,8 +178,7 @@
(string-append "PREFIX=" out)
(string-append "BINDIR=" out "/bin")
(string-append "DATADIR=" out "/share")
- (string-append "PLUGINDIR=" out "/lib/qt5/plugins")))
- #t))
+ (string-append "PLUGINDIR=" out "/lib/qt5/plugins")))))
(add-after 'install 'qt-wrap
(assoc-ref qt:%standard-phases 'qt-wrap)))))
(native-inputs
@@ -2173,7 +2172,7 @@ contain over 620 classes.")
(inputs
`(("python" ,python-wrapper)
("python-sip" ,python-sip)
- ("python-pyqt" ,python-pyqt)
+ ("python-pyqt" ,python-pyqt-without-qtwebkit)
("qtbase" ,qtbase-5)
("qtsvg" ,qtsvg)
("qtdeclarative" ,qtdeclarative)
@@ -2232,7 +2231,9 @@ set of three modules. Prior to v5.12 these bindings were part of PyQt
itself.")
(license license:gpl3)))
-;; XXX: This is useful because qtwebkit does not build reliably at this time.
+;; XXX: This is useful for removing qtwebkit from other packages' dependency
+;; graphs, as well as for preventing python-pyqtwebengine from transitively
+;; depending on qtwebkit.
;; Ultimately, it would be nicer to have a more modular set of python-pyqt-*
;; packages that could be used together.
(define-public python-pyqt-without-qtwebkit