summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm51
1 files changed, 41 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f19f0ed285..75682be6ab 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12970,12 +12970,45 @@ time.")
(inputs
(list inkscape pandoc))
(native-inputs
- (list python-ipykernel
- ;; Adding ipywidgets would create a cycle.
- ;;python-ipywidgets
- ;;python-pyppeteer ;TODO: package me
- python-pytest
- python-pytest-xdist))
+ `(("python-ipykernel" ,python-ipykernel)
+ ;; XXX: Disabled, not in guix.
+ ;;("python-pyppeteer" ,python-pyppeteer)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-dependency" ,python-pytest-dependency)
+ ("texlive" ,(texlive-updmap.cfg
+ (list texlive-adjustbox
+ texlive-amsfonts
+ texlive-booktabs
+ texlive-caption
+ texlive-eurosym
+ texlive-fancyvrb
+ texlive-fonts-rsfs
+ texlive-fontspec
+ texlive-grffile
+ texlive-hyperref
+ texlive-iftex
+ texlive-jknappen
+ texlive-latex-amsmath
+ texlive-latex-enumitem
+ texlive-latex-float
+ texlive-latex-geometry
+ texlive-latex-jknapltx
+ texlive-latex-parskip
+ texlive-latex-trimspaces
+ texlive-latex-ucs
+ texlive-latex-upquote
+ texlive-lm
+ texlive-mathpazo
+ texlive-ms
+ texlive-oberdiek
+ texlive-stringenc
+ texlive-tcolorbox
+ texlive-titling
+ texlive-tools
+ texlive-ulem
+ texlive-xcolor
+ texlive-zapfding)))))
(propagated-inputs
(list python-beautifulsoup4
python-bleach
@@ -15607,9 +15640,7 @@ syntax highlighting, markdown and more to the terminal.")
(list which))
(inputs
;; python-magic needs to be able to find libmagic.so.
- ;; Use a newer version because 5.39 returns bogus for some archives
- ;; (notably Chromium .crx extensions), which breaks e.g. 'diffoscope'.
- (list file-next))
+ (list file))
(synopsis "File type identification using libmagic")
(description
"This module uses ctypes to access the libmagic file type
@@ -26247,7 +26278,7 @@ By default it uses the open Python vulnerability database Safety DB.")
(native-inputs
`(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
texlive-fonts-ec
- texlive-generic-iftex
+ texlive-iftex
texlive-hyperref
texlive-oberdiek
texlive-lm