summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7c5e5651c8..98c5e87888 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2014, 2015 Mark H Weaver <[email protected]>
;;; Copyright © 2015 Cyril Roelandt <[email protected]>
;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <[email protected]>
-;;; Copyright © 2016, 2019 Hartmut Goebel <[email protected]>
+;;; Copyright © 2016, 2019, 2022 Hartmut Goebel <[email protected]>
;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2015, 2017 Ben Woodcroft <[email protected]>
;;; Copyright © 2015, 2016 Christine Lemmer-Webber <[email protected]>
@@ -2805,6 +2805,25 @@ APIs.")
than Python’s urllib2 library.")
(license license:asl2.0)))
+(define-public python-requests-kerberos
+ (package
+ (name "python-requests-kerberos")
+ (version "0.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "requests-kerberos" version))
+ (sha256
+ (base32
+ "1lbgjs779cjxhz07lfl9dbyp3qfh8a3ir2393042wfg518jd3afd"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-cryptography python-pyspnego
+ python-requests))
+ (home-page "https://github.com/requests/requests-kerberos")
+ (synopsis "Kerberos authentication handler for python-requests")
+ (description "This package provides a Kerberos authentication handler for
+python-requests.")
+ (license license:isc)))
+
(define-public python-requests-unixsocket
(package
(name "python-requests-unixsocket")