summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm27
1 files changed, 12 insertions, 15 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1046602800..8cf9e74f68 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -174,9 +174,9 @@ tests in cram.")
(add-installed-pythonpath inputs outputs)
(invoke "pytest")))))))
(native-inputs
- (list python-pytest-flake8 python-pytest-xdist-next python-tabulate))
+ (list python-pytest-flake8 python-pytest-xdist python-tabulate))
(propagated-inputs
- (list python-pytest-6 python-six))
+ (list python-pytest python-six))
(home-page "https://github.com/nicoulaj/pytest-csv")
(synopsis "CSV reporter for Pytest")
(description "This package provides a plugin for Pytest that enables a
@@ -249,7 +249,10 @@ are useful when writing automated tests in Python.")
(file-name (git-file-name name version))
(sha256
(base32
- "1915ab77nfb1rfw4i2ps0zy19wpf20lwxn81qxxbwyd2gy7m0fn8"))))
+ "1915ab77nfb1rfw4i2ps0zy19wpf20lwxn81qxxbwyd2gy7m0fn8"))
+ (modules '((guix build utils)))
+ (snippet '(substitute* "setup.py"
+ (("'coverage>=4.1,<6.0',") "'coverage',")))))
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
@@ -260,7 +263,8 @@ are useful when writing automated tests in Python.")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(if tests?
- (invoke "pytest" "-vv")
+ ;; Test fails for unknown reasons. No fix available.
+ (invoke "pytest" "-vv" "-k" "not test_reporter_with_branches")
(format #t "test suite not run~%")))))))
(propagated-inputs
(list python-coverage python-docopt python-pyyaml python-requests))
@@ -1147,25 +1151,18 @@ compliance.")
(define-public python-pytest-isort
(package
(name "python-pytest-isort")
- (version "2.0.0")
+ (version "3.1.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "pytest-isort" version))
+ (uri (pypi-uri "pytest_isort" version))
(sha256
- (base32 "05wi28zlqk3jafpjal8j523y5jcsx3xl3id9rx93qfjgkif8q6l2"))))
+ (base32 "0v0qa5l22y3v0nfkpvghbinzyj2rh4f54k871lrp992lbvf02y06"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest")))))))
+ `(#:tests? #f)) ; No tests in PyPi tarball.
(propagated-inputs
(list python-isort python-pytest))
- (native-inputs
- (list python-mock))
(home-page "https://github.com/moccu/pytest-isort/")
(synopsis "Pytest plugin to check import ordering using isort")
(description