summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/u-boot-patman-fix-help.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/u-boot-patman-fix-help.patch')
-rw-r--r--gnu/packages/patches/u-boot-patman-fix-help.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/gnu/packages/patches/u-boot-patman-fix-help.patch b/gnu/packages/patches/u-boot-patman-fix-help.patch
deleted file mode 100644
index 89bac06c2f..0000000000
--- a/gnu/packages/patches/u-boot-patman-fix-help.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Upstream status: https://patchwork.ozlabs.org/project/uboot/list/?series=333156
-
-diff --git a/tools/patman/main.py b/tools/patman/main.py
-index 5a7756a221..bf300c6e64 100755
---- a/tools/patman/main.py
-+++ b/tools/patman/main.py
-@@ -7,6 +7,7 @@
- """See README for more information"""
-
- from argparse import ArgumentParser
-+import importlib.resources
- import os
- import re
- import shutil
-@@ -163,11 +164,8 @@ elif args.cmd == 'send':
- fd.close()
-
- elif args.full_help:
-- tools.print_full_help(
-- os.path.join(os.path.dirname(os.path.realpath(sys.argv[0])),
-- 'README.rst')
-- )
--
-+ with importlib.resources.path('patman', 'README.rst') as readme:
-+ tools.print_full_help(str(readme))
- else:
- # If we are not processing tags, no need to warning about bad ones
- if not args.process_tags:
-diff --git a/tools/patman/setup.py b/tools/patman/setup.py
-index 43fdc00ce6..ce9bb4aa63 100644
---- a/tools/patman/setup.py
-+++ b/tools/patman/setup.py
-@@ -7,6 +7,6 @@ setup(name='patman',
- scripts=['patman'],
- packages=['patman'],
- package_dir={'patman': ''},
-- package_data={'patman': ['README']},
-+ package_data={'patman': ['README.rst']},
- classifiers=['Environment :: Console',
- 'Topic :: Software Development'])