summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/csvkit-set-locale-for-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/csvkit-set-locale-for-tests.patch')
-rw-r--r--gnu/packages/patches/csvkit-set-locale-for-tests.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/csvkit-set-locale-for-tests.patch b/gnu/packages/patches/csvkit-set-locale-for-tests.patch
new file mode 100644
index 0000000000..52f6a5d517
--- /dev/null
+++ b/gnu/packages/patches/csvkit-set-locale-for-tests.patch
@@ -0,0 +1,13 @@
+Contents copied from python-agate. See
+https://github.com/wireservice/agate/issues/712 for the source and the
+rationale.
+
+diff --git a/tests/__init__.py b/tests/__init__.py
+index e69de29..ee8beb5 100644
+--- a/tests/__init__.py
++++ b/tests/__init__.py
+@@ -0,0 +1,4 @@
++import locale
++
++# The test fixtures can break if the locale is non-US.
++locale.setlocale(locale.LC_ALL, 'en_US.UTF-8')