summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9bf5f03390..25de298d5a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2014 Mathieu Lirzin <[email protected]>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <[email protected]>
;;; Copyright © 2015 Sou Bunnbu <[email protected]>
-;;; Copyright © 2015 Mark H Weaver <[email protected]>
+;;; Copyright © 2015, 2018 Mark H Weaver <[email protected]>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <[email protected]>
;;; Copyright © 2015 Fabian Harfert <[email protected]>
;;; Copyright © 2016 Roel Janssen <[email protected]>
@@ -2796,12 +2796,12 @@ to BMP, JPEG or PNG image formats.")
;; of Debian's Maxima package.
;; If Maxima can successfully run this, the binary to be installed
;; should be fine.
- (zero?
- (system
- (string-append "./maxima-local "
- "--lisp=gcl "
- "--batch-string=\"run_testsuite();\" "
- "| grep -q \"No unexpected errors found\"")))))
+ (invoke "sh" "-c"
+ (string-append
+ "./maxima-local "
+ "--lisp=gcl "
+ "--batch-string=\"run_testsuite();\" "
+ "| grep -q \"No unexpected errors found\""))))
;; Make sure the doc and emacs files are found in the
;; standard location. Also configure maxima to find gnuplot
;; without having it on the PATH.