summaryrefslogtreecommitdiff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index bc8476e056..ce131a5835 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -9,6 +9,8 @@
;;; Copyright © 2021 Noisytoot <[email protected]>
;;; Copyright © 2021 Zhu Zihao <[email protected]>
;;; Copyright © 2021 Petr Hodina <[email protected]>
+;;; Copyright © 2022 jgart <[email protected]>
+;;; Copyright © 2022 Vinicius Monego <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -439,14 +441,21 @@ with a few extensions.")
(define-public python-mistletoe
(package
(name "python-mistletoe")
- (version "0.7.2")
+ (version "0.8.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "mistletoe" version))
(sha256
- (base32 "18z6hqfnfjqnrcgfgl5pkj9ggf9yx0yyy94azcn1qf7hqn6g3l14"))))
+ (base32 "0h8ydzxlfzmspiz8lcm13qp720kfsxiky0qqnc2mxf4qzm16m326"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "unittest" "discover" "test")))))))
(home-page "https://github.com/miyuchina/mistletoe")
(synopsis "Extensible Markdown parser in pure Python")
(description