summaryrefslogtreecommitdiff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index ba3fc6bc79..62be8f0c4a 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2019, 2021 Maxim Cournoyer <[email protected]>
;;; Copyright © 2020 John Doe <[email protected]>
+;;; Copyright © 2024 Janneke Nieuwenhuizen <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,7 +61,12 @@
`(;; Prevent the build system from passing -march and -mtune to the
;; compiler. See "ax_cc_maxopt.m4" and "ax_gcc_archflag.m4".
#:configure-flags '("--enable-portable-binary"
- "--without-gcc-arch")))
+ "--without-gcc-arch"
+ ,@(if (or (target-hurd64?) (%current-target-system))
+ (list (string-append
+ "CFLAGS=-g -O2"
+ " -Wno-implicit-function-declaration"))
+ '()))))
(outputs '("out" "debug"))
(synopsis "Foreign function call interface library")
(description