summaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 37d58f5d6b..8c484efb2d 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
-;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2021 WinterHound <winterhound@yandex.com>
@@ -151,7 +151,7 @@ irssi, but graphical.")
(define-public irssi
(package
(name "irssi")
- (version "1.2.3")
+ (version "1.4.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/irssi/irssi/"
@@ -159,7 +159,7 @@ irssi, but graphical.")
version ".tar.xz"))
(sha256
(base32
- "17vninwcdfxw39xl2q55qircckckjk2xlvkvlwgj5lhlxppvyix6"))))
+ "00bmwkpzhqqnsajakk7dviap1i8s89375kwpdyxg65ms3ds94xka"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -172,8 +172,7 @@ irssi, but graphical.")
(string-append "--prefix=" out)
(string-append "--enable-true-color")
(string-append "--with-proxy")
- (string-append "--with-socks")
- (string-append "--with-bot")))))
+ (string-append "--with-socks")))))
(add-before 'check 'set-home
(lambda _
(setenv "HOME" (getcwd)))))))
@@ -182,10 +181,14 @@ irssi, but graphical.")
(native-inputs
(list pkg-config))
(home-page "https://irssi.org/")
- (synopsis "Terminal-based IRC client")
+ (synopsis "Extensible terminal-based IRC client")
(description
- "Irssi is a terminal based IRC client for UNIX systems. It also supports
-SILC and ICB protocols via plugins.")
+ "Irssi is a text terminal-based @acronym{IRC, Internet relay chat} client.
+It is completely themable and extensible through Perl scripts, of which many
+have already been written by the community.
+
+Plug-ins add support for other protocols like @acronym{SILC, Secure Internet Live
+Conferencing} and @acronym{ICB, Internet Citizen's Band}.")
(license license:gpl2+)))
(define-public weechat
@@ -261,7 +264,7 @@ using a mouse. It is customizable and extensible with plugins and scripts.")
(define-public srain
(package
(name "srain")
- (version "1.3.2")
+ (version "1.4.0")
(source
(origin
(method git-fetch)
@@ -270,7 +273,7 @@ using a mouse. It is customizable and extensible with plugins and scripts.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "16nsxicixp7194bkiiyj7zrg05lhcp0xblqsbv6dq1lxd5wd3i96"))))
+ (base32 "113nvai3nr2c8mrr5q56fb7smg5awgb2f243sib4k1zj437v9q51"))))
(build-system meson-build-system)
(arguments
`(#:tests? #f ;there are no tests