summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 757c4f876b..bf88930b9c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2016 Patrick Hetu <[email protected]>
;;; Copyright © 2016 Nikita <[email protected]>
;;; Copyright © 2017 Roel Janssen <[email protected]>
-;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2017, 2019, 2020 Marius Bakke <[email protected]>
;;; Copyright © 2018 Alex Vong <[email protected]>
;;; Copyright © 2018, 2020 Arun Isaac <[email protected]>
@@ -1562,14 +1562,14 @@ guile-gnome-platform (GNOME developer libraries), and guile-gtksourceview.")
(define-public cairomm
(package
(name "cairomm")
- (version "1.16.0")
+ (version "1.16.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.cairographics.org/releases/"
name "-" version ".tar.xz"))
(sha256
(base32
- "1ya4y7qa000cjawqwswbqv26y5icfkmhs5iiiil4dxgrqn91923y"))))
+ "1im2yjzvjfx8s7cal9kwq23z936kppfmyag2zsnbim4dx7c60q3g"))))
(build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
@@ -1587,18 +1587,17 @@ guile-gnome-platform (GNOME developer libraries), and guile-gtksourceview.")
(mkdir-p (string-append doc "/share"))
(rename-file
(string-append out "/share/doc")
- (string-append doc "/share/doc"))
- #t))))))
+ (string-append doc "/share/doc"))))))))
(native-inputs
- `(("boost" ,boost)
- ("dot" ,graphviz)
- ("doxygen" ,doxygen)
- ("mm-common" ,mm-common)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("xsltproc" ,libxslt)))
+ (list boost
+ doxygen
+ graphviz
+ mm-common
+ perl
+ pkg-config
+ libxslt))
(inputs
- `(("fontconfig" ,fontconfig)))
+ (list fontconfig))
(propagated-inputs
(list libsigc++ cairo))
(home-page "https://cairographics.org/")