summaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 58c0fa82fe..2b7438c902 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Efraim Flashner <[email protected]>
;;; Copyright © 2016 Theodoros Foradis <[email protected]>
;;; Copyright © 2017 Ricardo Wurmus <[email protected]>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2017 Gábor Boskovits <[email protected]>
;;; Copyright © 2018 Mathieu Lirzin <[email protected]>
;;;
@@ -150,11 +150,12 @@ visualization tool suite.")
"07mqx09jxh8cv9753y2d2jsv7wp8vjmrd7zcfpbrddz3wc9kx705"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-cons-before
- 'check 'pre-check
- (lambda _
- (chmod "test/boolean/test.sh" #o777))
- %standard-phases)
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ (chmod "test/boolean/test.sh" #o777)
+ #t)))
;; Some data files used by the test suite are missing.
;; See <http://sourceforge.net/p/gts/bugs/41/>.