summaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm53
1 files changed, 24 insertions, 29 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index f1038a83eb..d98041d73a 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -68,7 +68,7 @@
(define-public graphviz
(package
(name "graphviz")
- (version "2.49.0")
+ (version "7.0.1")
(source (origin
(method url-fetch)
(uri (string-append "https://gitlab.com/api/v4/projects/4207231"
@@ -76,24 +76,16 @@
version "/graphviz-" version ".tar.xz"))
(sha256
(base32
- "042s6mbi681pwgffqww2ap780230nrsrfpfiz9a41dcjb5a0m524"))))
+ "1b6x3g03j7q77lzyvdp34hkzld5sg1l1ippc6sh1qxnmm59xs3ly"))))
(build-system gnu-build-system)
(arguments
;; FIXME: rtest/rtest.sh is a ksh script (!). Add ksh as an input.
(list #:tests? #f
#:phases
#~(modify-phases %standard-phases
- (add-after 'install 'move-docs
+ (add-after 'install 'move-guile-bindings
(lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc")))
- (mkdir-p (string-append doc "/share/graphviz"))
- (rename-file (string-append out "/share/graphviz/doc")
- (string-append doc "/share/graphviz/doc")))))
- (add-after 'move-docs 'move-guile-bindings
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib"))
+ (let* ((lib (string-append #$output "/lib"))
(extdir (string-append lib "/guile/"
#$(version-major+minor
(package-version
@@ -105,22 +97,24 @@
(string-append extdir
"/libgv_guile.so"))))))))
(inputs
- `(("libXrender" ,libxrender)
- ("libX11" ,libx11)
- ("gts" ,gts)
- ("gd" ,gd)
- ("guile" ,guile-3.0) ;Guile bindings
- ("pango" ,pango)
- ("fontconfig" ,fontconfig)
- ("freetype" ,freetype)
- ("libltdl" ,libltdl)
- ("libXaw" ,libxaw)
- ("expat" ,expat)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)))
+ (list libxrender
+ libx11
+ gts
+ gd
+ guile-3.0 ;Guile bindings
+ pango
+ fontconfig
+ freetype
+ libltdl
+ libxaw
+ expat
+ libjpeg-turbo
+ libpng))
(native-inputs
- (list bison swig pkg-config))
- (outputs '("out" "doc")) ; 5 MiB of html + pdfs
+ (list bison
+ pkg-config
+ swig))
+ (outputs '("out" "doc")) ;5 MiB of html + pdfs
(home-page "https://www.graphviz.org/")
(synopsis "Graph visualization software")
(description
@@ -200,6 +194,7 @@ interfaces for other technical domains.")
(list unzip
;; For tests.
graphviz
+ python-mock
python-pytest
python-pytest-cov
python-pytest-mock))
@@ -351,7 +346,7 @@ Graphviz and LaTeX.")
`("PATH" ":" prefix
(,(dirname (search-input-file inputs "bin/dot"))))))))))
(inputs
- (list atk
+ (list at-spi2-core
(librsvg-for-system)
harfbuzz
graphviz
@@ -433,8 +428,8 @@ graphs in Graphviz's DOT language, written in pure Python.")
;; the resulting generated TeX files, which \usepackage them.
texlive-bin
texlive-amsmath
+ texlive-graphics
texlive-latex-geometry
- texlive-latex-graphics
texlive-latex-base
texlive-latex-preview
texlive-latex-xkeyval