summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index a7afb6502f..7537728b27 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -13191,6 +13191,30 @@ supported by the time package
@end itemize")
(license license:expat)))
+(define-public go-github-com-twpayne-go-shell
+ (package
+ (name "go-github-com-twpayne-go-shell")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/twpayne/go-shell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rnwdlhiakcigmz55fhn0wib6vi064cqxfq512mi880j9yqx4114"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/twpayne/go-shell"))
+ (native-inputs
+ (list go-github-com-alecthomas-assert-v2))
+ (home-page "https://github.com/twpayne/go-shell")
+ (synopsis "Shell across multiple platforms")
+ (description
+ "Package @code{shell} returns a user's shell across multiple platforms.")
+ (license license:expat)))
+
(define-public go-github-com-twpayne-go-vfs
(package
(name "go-github-com-twpayne-go-vfs")